summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-02-16 01:37:45 -0300
committerGonzalo Exequiel Pedone2024-02-16 01:37:45 -0300
commit919b1440110c6e5582c96132985e401d1c2ff4fd (patch)
tree3b5da4e765a7486b37ea1793720f44c93dd6f24d
downloadaur-919b1440110c6e5582c96132985e401d1c2ff4fd.tar.gz
New package.
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD55
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..55bffc357d1a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = android-armv7a-eabi-libgcrypt
+ pkgdesc = General purpose cryptographic library based on the code from GnuPG (android)
+ pkgver = 1.10.3
+ pkgrel = 1
+ url = https://www.gnupg.org
+ arch = any
+ license = LGPL
+ depends = android-armv7a-eabi-libgpg-error
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://gnupg.org/ftp/gcrypt/libgcrypt/libgcrypt-1.10.3.tar.bz2
+ source = https://gnupg.org/ftp/gcrypt/libgcrypt/libgcrypt-1.10.3.tar.bz2.sig
+ validpgpkeys = AC8E115BF73E2D8D47FA9908E98E9B2D19C6C8BD
+ sha256sums = 8b0870897ac5ac67ded568dcfadf45969cfa8a6beb0fd60af2a9eadc2a3272aa
+ sha256sums = SKIP
+
+pkgname = android-armv7a-eabi-libgcrypt
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f3ed6a151b9f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+glib/
+pkg/
+src/
+*.log
+*.tar
+*.xz
+*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..713cc4632b1d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+
+_android_arch=armv7a-eabi
+
+pkgname=android-${_android_arch}-libgcrypt
+pkgver=1.10.3
+pkgrel=1
+arch=('any')
+pkgdesc="General purpose cryptographic library based on the code from GnuPG (android)"
+url="https://www.gnupg.org"
+license=('LGPL')
+depends=("android-${_android_arch}-libgpg-error")
+options=(!strip !buildflags staticlibs !emptydirs)
+# https://www.gnupg.org/download/integrity_check.html
+source=(https://gnupg.org/ftp/gcrypt/libgcrypt/libgcrypt-${pkgver}.tar.bz2{,.sig})
+sha256sums=('8b0870897ac5ac67ded568dcfadf45969cfa8a6beb0fd60af2a9eadc2a3272aa'
+ 'SKIP')
+validpgpkeys=('AC8E115BF73E2D8D47FA9908E98E9B2D19C6C8BD') # Niibe Yutaka (GnuPG Release Key)
+
+prepare() {
+ cd "$srcdir/libgcrypt-${pkgver}"
+ source android-env ${_android_arch}
+
+ # tests fail due to systemd+libseccomp preventing memory syscalls when building in chroots
+ # t-secmem: line 176: gcry_control (GCRYCTL_INIT_SECMEM, pool_size, 0) failed: General error
+ # FAIL: t-secmem
+ # t-sexp: line 1174: gcry_control (GCRYCTL_INIT_SECMEM, 16384, 0) failed: General error
+ # FAIL: t-sexp
+ sed -i "s:t-secmem::" tests/Makefile.am
+ sed -i "s:t-sexp::" tests/Makefile.am
+ autoreconf -vfi
+}
+
+build() {
+ cd "$srcdir/libgcrypt-${pkgver}"
+ source android-env ${_android_arch}
+
+ export LDFLAGS="-Wl,--undefined-version ${LDFLAGS}"
+
+ android-${_android_arch}-configure \
+ --infodir="${ANDROID_PREFIX_SHARE}/info/libgcrypt" \
+ --disable-padlock-support
+ make $MAKEFLAGS
+}
+
+package() {
+ cd "$srcdir/libgcrypt-${pkgver}"
+ source android-env ${_android_arch}
+
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}/${ANDROID_PREFIX_BIN}"
+ ${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}"/${ANDROID_PREFIX_LIB}/*.so
+ ${ANDROID_STRIP} -g "$pkgdir"/${ANDROID_PREFIX_LIB}/*.a
+}