summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2018-11-28 17:47:29 -0300
committerGonzalo Exequiel Pedone2018-11-28 17:47:29 -0300
commit16fa2b23bedcd57a44ba62998ba6e277b7d78055 (patch)
tree167f8651f8f83e5fdb9a1b663c0d7b32d121a9de
parentadd7ce37eeba003556d9dae19df77945971e3ab9 (diff)
downloadaur-16fa2b23bedcd57a44ba62998ba6e277b7d78055.tar.gz
Fixed androiddeployqt search paths.
-rw-r--r--.SRCINFO6
-rw-r--r--0003-Fix-androiddeployqt-search-paths.patch20
-rw-r--r--PKGBUILD22
3 files changed, 39 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c087a8aa074..fd42876169dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# jue nov 22 19:10:34 UTC 2018
+# miƩ nov 28 20:46:22 UTC 2018
pkgbase = android-armv7a-eabi-qt5
pkgdesc = Qt 5 for Android
pkgver = 5.11.2
- pkgrel = 1
+ pkgrel = 2
url = https://www.qt.io
arch = x86_64
groups = android-qt5
@@ -33,9 +33,11 @@ pkgbase = android-armv7a-eabi-qt5
source = http://download.qt-project.org/official_releases/qt/5.11/5.11.2/single/qt-everywhere-src-5.11.2.tar.xz
source = 0001-Fix-clang-build.patch
source = 0002-Disable-mapbox.patch
+ source = 0003-Fix-androiddeployqt-search-paths.patch
md5sums = 152a8ade9c11fe33ff5bc95310a1bb64
md5sums = 511eafcabe9e0c6210f1dc5e26daa5c8
md5sums = 20d8bdd24102e9011b561b7361394728
+ md5sums = 549cf284d0cea4d618ad2d49532ea2db
pkgname = android-armv7a-eabi-qt5
diff --git a/0003-Fix-androiddeployqt-search-paths.patch b/0003-Fix-androiddeployqt-search-paths.patch
new file mode 100644
index 000000000000..cf37f39ae6ab
--- /dev/null
+++ b/0003-Fix-androiddeployqt-search-paths.patch
@@ -0,0 +1,20 @@
+--- a/qtbase/src/tools/androiddeployqt/main.cpp 2018-09-13 01:25:10.000000000 -0300
++++ b/qtbase/src/tools/androiddeployqt/main.cpp 2018-11-28 11:01:22.654317806 -0300
+@@ -1629,7 +1629,7 @@
+ rootPath += QLatin1Char('/');
+
+ QStringList importPaths;
+- importPaths += shellQuote(options->qtInstallDirectory + QLatin1String("/qml"));
++ importPaths += shellQuote(options->qtInstallDirectory + QLatin1String("/lib/qt/qml"));
+ importPaths += rootPath;
+ for (const QString &qmlImportPath : qAsConst(options->qmlImportPaths))
+ importPaths += shellQuote(qmlImportPath);
+@@ -1760,7 +1760,7 @@
+ return false;
+
+ // Jam in the dependencies of the platform plugin, since the application will crash without it
+- if (!readDependenciesFromElf(options, options->qtInstallDirectory + QLatin1String("/plugins/platforms/android/libqtforandroid.so"), &usedDependencies, &remainingDependencies))
++ if (!readDependenciesFromElf(options, options->qtInstallDirectory + QLatin1String("/lib/qt/plugins/platforms/android/libqtforandroid.so"), &usedDependencies, &remainingDependencies))
+ return false;
+
+ QString qtDir = options->qtInstallDirectory + QLatin1Char('/');
diff --git a/PKGBUILD b/PKGBUILD
index b81c89cbf15a..8ed1b69d2bdd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,7 +28,7 @@ fi
pkgname=android-${_android_arch}-qt5
pkgver=5.11.2
-pkgrel=1
+pkgrel=2
pkgdesc="Qt 5 for Android"
arch=('x86_64')
url='https://www.qt.io'
@@ -78,10 +78,12 @@ options=('!strip'
_pkgfqn="qt-everywhere-src-${pkgver}"
source=("http://download.qt-project.org/official_releases/qt/${pkgver:0:4}/${pkgver}/single/${_pkgfqn}.tar.xz"
"0001-Fix-clang-build.patch"
- "0002-Disable-mapbox.patch")
+ "0002-Disable-mapbox.patch"
+ "0003-Fix-androiddeployqt-search-paths.patch")
md5sums=('152a8ade9c11fe33ff5bc95310a1bb64'
'511eafcabe9e0c6210f1dc5e26daa5c8'
- '20d8bdd24102e9011b561b7361394728')
+ '20d8bdd24102e9011b561b7361394728'
+ '549cf284d0cea4d618ad2d49532ea2db')
_pref=/opt/android-libs/$_android_arch
@@ -91,6 +93,11 @@ prepare() {
# Platform specific patches.
patch -Np1 -i "../0001-Fix-clang-build.patch"
patch -Np1 -i "../0002-Disable-mapbox.patch"
+ patch -Np1 -i "../0003-Fix-androiddeployqt-search-paths.patch"
+ sed -i "s/android-16/android-$ANDROID_MINIMUM_PLATFORM/g" qtbase/mkspecs/features/android/sdk.prf
+ sed -i "s/android-16/android-$ANDROID_MINIMUM_PLATFORM/g" qtbase/src/android/jar/jar.pro
+ sed -i "s/android-16/android-$ANDROID_MINIMUM_PLATFORM/g" qtgamepad/src/plugins/gamepads/android/jar/jar.pro
+ sed -i "s/android-16/android-$ANDROID_MINIMUM_PLATFORM/g" qtbase/configure.pri
}
get_last() {
@@ -209,9 +216,10 @@ package() {
esac
STRIP=${ANDROID_NDK_ROOT}/toolchains/${toolchain}/prebuilt/linux-x86_64/${stripFolder}/bin/strip
- find ${pkgdir}/${_pref}/bin ! -name '*.pl' -exec ${STRIP} {} \;
- find ${pkgdir}/${_pref}/lib -name 'lib*.so' -exec ${STRIP} {} \;
- find ${pkgdir}/${_pref}/lib \( -name 'lib*.a' ! -name 'libQt5Bootstrap.a' ! -name 'libQt5QmlDevTools.a' \) -exec ${STRIP} {} \;
- find ${pkgdir}/${_pref}/lib/qt/plugins -name 'lib*.so' -exec ${STRIP} {} \;
+ find ${pkgdir}/${_pref}/bin -type f ! -name '*.pl' -exec strip {} \;
+ find ${pkgdir}/${_pref}/lib -type f -name 'lib*.so' -exec ${STRIP} {} \;
+ find ${pkgdir}/${_pref}/lib -type f \( -name 'lib*.a' ! -name 'libQt5Bootstrap.a' ! -name 'libQt5QmlDevTools.a' \) -exec ${STRIP} {} \;
+ find ${pkgdir}/${_pref}/lib/qt/plugins -type f -name 'lib*.so' -exec ${STRIP} {} \;
sed -i '/QMAKE_PRL_BUILD_DIR/d' ${pkgdir}/${_pref}/lib/lib*.prl
+ sed -i 's/\"plugins\//\"lib\/qt\/plugins\//g' ${pkgdir}/${_pref}/lib/*-android-dependencies.xml
}