summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhang Hai2017-04-19 15:05:49 +0800
committerZhang Hai2017-04-19 15:05:49 +0800
commit95803a8352c769823cbea11e94332d0f257663a5 (patch)
tree304840e8c5d2439e4af4c9e4a22484bf7efc6799
downloadaur-95803a8352c769823cbea11e94332d0f257663a5.tar.gz
Initial commit.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD39
-rw-r--r--android-emulator.csh2
-rw-r--r--android-emulator.install3
-rw-r--r--android-emulator.sh2
5 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..49216e5181bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Wed Apr 19 07:00:24 UTC 2017
+pkgbase = android-emulator
+ pkgdesc = Google Android Emulator
+ pkgver = 26.0.1
+ pkgrel = 1
+ url = https://developer.android.com/studio/releases/emulator.html
+ install = android-emulator.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = android-sdk
+ source = https://dl.google.com/android/repository/emulator-linux-3887480.zip
+ source = android-emulator.sh
+ source = android-emulator.csh
+ sha1sums = 81cba3f2b698dbbc450873916b30ac2ca8c104f8
+ sha1sums = 4537a7ce30bedf87cedafc2020822219ad58310d
+ sha1sums = 2fb371b5774b67143f0610dfbec4963a4e2f11cc
+
+pkgname = android-emulator
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..313a56b0b295
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Zhang Hai <dreaming.in.code.zh@gmail.com>
+
+pkgname=android-emulator
+pkgver=26.0.1
+pkgrel=1
+pkgdesc='Google Android Emulator'
+arch=('i686' 'x86_64')
+url='https://developer.android.com/studio/releases/emulator.html'
+license=('custom')
+depends=('android-sdk')
+install="${pkgname}.install"
+source=('https://dl.google.com/android/repository/emulator-linux-3887480.zip'
+ "${pkgname}.sh"
+ "${pkgname}.csh")
+sha1sums=('81cba3f2b698dbbc450873916b30ac2ca8c104f8'
+ '4537a7ce30bedf87cedafc2020822219ad58310d'
+ '2fb371b5774b67143f0610dfbec4963a4e2f11cc')
+
+package() {
+
+ install -Dm755 "${pkgname}.sh" "${pkgdir}/etc/profile.d/${pkgname}.sh"
+ install -Dm755 "${pkgname}.csh" "${pkgdir}/etc/profile.d/${pkgname}.csh"
+
+ rm -rf emulator/lib{,64}/libstdc++
+
+ if [[ "${CARCH}" = i686 ]]; then
+ rm -rf emulator/lib64/
+ fi
+
+ cp -a emulator "${pkgdir}/opt/android-sdk/"
+
+ # Fix broken permissions
+ chmod -R o=g "${pkgdir}/opt/android-sdk/emulator"
+ find "${pkgdir}/opt/android-sdk/emulator" -perm 744 -exec chmod 755 {} +
+}
+
+# getver: https://developer.android.com/studio/releases/emulator.html
+# see https://dl.google.com/android/repository/repository2-1.xml for new versions
+# vim:set ts=2 sw=2 et:
diff --git a/android-emulator.csh b/android-emulator.csh
new file mode 100644
index 000000000000..0c4f307631c8
--- /dev/null
+++ b/android-emulator.csh
@@ -0,0 +1,2 @@
+setenv ANDROID_HOME /opt/android-sdk
+setenv PATH "${PATH}:${ANDROID_HOME}/emulator"
diff --git a/android-emulator.install b/android-emulator.install
new file mode 100644
index 000000000000..bedaa1d6b5b5
--- /dev/null
+++ b/android-emulator.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo You need to source /etc/profile or relogin to add the Android Emulator to your path.
+}
diff --git a/android-emulator.sh b/android-emulator.sh
new file mode 100644
index 000000000000..b3caba890544
--- /dev/null
+++ b/android-emulator.sh
@@ -0,0 +1,2 @@
+export ANDROID_HOME=/opt/android-sdk
+export PATH="${PATH}:${ANDROID_HOME}/emulator"