summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKppqju772020-11-07 11:51:42 +0100
committerKppqju772020-11-07 11:51:42 +0100
commit56d40cc8f203ad808066417a2e6d3e0a96447c85 (patch)
tree81f9e914521352538fa343b32895858fbf5b6647
parent40b63824ce5571ea1574d04227b2d01b13c2343a (diff)
downloadaur-56d40cc8f203ad808066417a2e6d3e0a96447c85.tar.gz
Update to r11
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD11
-rw-r--r--package.xml2
3 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b710902b6e92..8f175deddd26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = android-google-apis-x86-64-system-image-29
pkgdesc = Android with Google APIs x86_64 Atom System Image, API-29
- pkgver = r10
+ pkgver = r11
pkgrel = 1
url = https://software.intel.com/en-us/android/tools
arch = any
license = custom
- depends = android-platform-29
- optdepends = qemu
- optdepends = libvirt
provides = android-google-apis-x86-64-system-image-29
conflicts = android-google-apis-x86-64-system-image-29
options = !strip
- source = http://dl-ssl.google.com/android/repository/sys-img/google_apis/x86_64-29_r10.zip
+ source = http://dl-ssl.google.com/android/repository/sys-img/google_apis/x86_64-29_r11.zip
source = package.xml
- sha256sums = bdd82da247161e4464f6016a051b74d3dddf99f2a797d8ea5437ed6ca73b4e6a
- sha256sums = 4319fe5978d989d04ce2425de6e813a59f871e39233f3ff6b030619b7e4dcd71
+ sha256sums = 5029360d33a33baba23b0f224abf42e951a5d3596eccf4ef212c11236362d223
+ sha256sums = 6962710637ef177de9fb9a5f311a4d595d4cd402bba96e3fee9b44030feaa73b
pkgname = android-google-apis-x86-64-system-image-29
+ depends = android-platform-29
+ optdepends = qemu
+ optdepends = libvirt
diff --git a/PKGBUILD b/PKGBUILD
index d2d2d4be5b17..ee2a96ee7e60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,19 @@
pkgname=android-google-apis-x86-64-system-image-29
_apilevel=29
_arch=x86_64
-pkgver=r10
+pkgver=r11
pkgrel=1
pkgdesc="Android with Google APIs ${_arch} Atom System Image, API-${_apilevel}"
arch=('any')
url='https://software.intel.com/en-us/android/tools'
license=('custom')
-depends=("android-platform-${_apilevel}")
-optdepends=('qemu' 'libvirt')
provides=("${pkgname}")
conflicts=("${pkgname}")
options=('!strip')
source=("http://dl-ssl.google.com/android/repository/sys-img/google_apis/${_arch}-${_apilevel}_${pkgver}.zip"
"package.xml")
-sha256sums=('bdd82da247161e4464f6016a051b74d3dddf99f2a797d8ea5437ed6ca73b4e6a'
- '4319fe5978d989d04ce2425de6e813a59f871e39233f3ff6b030619b7e4dcd71')
+sha256sums=('5029360d33a33baba23b0f224abf42e951a5d3596eccf4ef212c11236362d223'
+ '6962710637ef177de9fb9a5f311a4d595d4cd402bba96e3fee9b44030feaa73b')
prepare() {
# Fix permissions
@@ -28,6 +26,9 @@ prepare() {
}
package() {
+ # Run dependencies
+ depends=("android-platform-${_apilevel}")
+ optdepends=('qemu' 'libvirt')
# Install files
install -d -m 755 "${pkgdir}/opt/android-sdk/system-images/android-${_apilevel}/google_apis"
cp -r "${_arch}" "${pkgdir}/opt/android-sdk/system-images/android-${_apilevel}/google_apis/"
diff --git a/package.xml b/package.xml
index 3c4203e64057..0a2def00b4b0 100644
--- a/package.xml
+++ b/package.xml
@@ -138,4 +138,4 @@ This is the Android Software Development Kit License Agreement
14.7 The License Agreement, and your relationship with Google under the License Agreement, shall be governed by the laws of the State of California without regard to its conflict of laws provisions. You and Google agree to submit to the exclusive jurisdiction of the courts located within the county of Santa Clara, California to resolve any legal matter arising from the License Agreement. Notwithstanding this, you agree that Google shall still be allowed to apply for injunctive remedies (or an equivalent type of urgent legal relief) in any jurisdiction.
-January 16, 2019</license><localPackage path="system-images;android-29;google_apis;x86_64" obsolete="false"><type-details xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:type="ns6:sysImgDetailsType"><api-level>29</api-level><tag><id>google_apis</id><display>Google APIs</display></tag><vendor><id>google</id><display>Google Inc.</display></vendor><abi>x86_64</abi></type-details><revision><major>10</major></revision><display-name>Google APIs Intel x86 Atom_64 System Image</display-name><uses-license ref="android-sdk-license"/><dependencies><dependency path="patcher;v4"/><dependency path="emulator"><min-revision><major>28</major><minor>1</minor><micro>9</micro></min-revision></dependency></dependencies></localPackage></ns2:repository> \ No newline at end of file
+January 16, 2019</license><localPackage path="system-images;android-29;google_apis;x86_64" obsolete="false"><type-details xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:type="ns6:sysImgDetailsType"><api-level>29</api-level><tag><id>google_apis</id><display>Google APIs</display></tag><vendor><id>google</id><display>Google Inc.</display></vendor><abi>x86_64</abi></type-details><revision><major>11</major></revision><display-name>Google APIs Intel x86 Atom_64 System Image</display-name><uses-license ref="android-sdk-license"/><dependencies><dependency path="patcher;v4"/><dependency path="emulator"><min-revision><major>28</major><minor>1</minor><micro>9</micro></min-revision></dependency></dependencies></localPackage></ns2:repository> \ No newline at end of file