summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-22 16:27:38 +0800
committerzxp198210052023-12-22 16:27:38 +0800
commitf38080c53dd5577ca23e1729002246ea4444f7e8 (patch)
treec75b4717aadba902fdac1b464ca2a882152bcd65
downloadaur-f38080c53dd5577ca23e1729002246ea4444f7e8.tar.gz
update to 1.1.21
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD59
-rw-r--r--android-knot.sh10
3 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cdff14b8dea8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = android-knot-bin
+ pkgdesc = An Android gadget that integrates common modules such as Todo, Notes and Reader and supports various clients (Win, Mac, Linux) for editing Todo and Notes.
+ pkgver = 1.1.21
+ pkgrel = 1
+ url = https://github.com/ic005k/Knot
+ arch = x86_64
+ license = MIT
+ makedepends = squashfuse
+ depends = nss
+ depends = gmp
+ depends = libgpg-error
+ depends = libglvnd
+ depends = libxcb
+ depends = e2fsprogs
+ depends = nspr
+ depends = alsa-lib
+ depends = expat
+ depends = libp11-kit
+ depends = freetype2
+ depends = fontconfig
+ depends = sqlite
+ depends = libx11
+ provides = android-knot=1.1.21
+ conflicts = android-knot
+ options = !strip
+ source = android-knot-1.1.21.AppImage::https://github.com/ic005k/Knot/releases/download/1.1.21/Knot-Linux-x86_64.AppImage
+ source = LICENSE-1.1.21::https://raw.githubusercontent.com/ic005k/Knot/1.1.21/LICENSE
+ source = android-knot.sh
+ sha256sums = 912ad18c9ff3223c4a15891a403a794031b6d9a811e6539a0399348df2489bf8
+ sha256sums = e81172c8f0c194e8fb34edd30b153e60407a094bbf2492abe4e012e6a1ad854a
+ sha256sums = aec1ed1418460a2f4ed06ef6790036b87ea4d36a03ea057de5212302f318cf79
+
+pkgname = android-knot-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a3212e5e004
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=android-knot-bin
+_pkgname=Knot
+pkgver=1.1.21
+pkgrel=1
+pkgdesc="An Android gadget that integrates common modules such as Todo, Notes and Reader and supports various clients (Win, Mac, Linux) for editing Todo and Notes."
+arch=("x86_64")
+url="https://github.com/ic005k/Knot"
+license=("MIT")
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
+depends=(
+ 'nss'
+ 'gmp'
+ 'libgpg-error'
+ 'libglvnd'
+ 'libxcb'
+ 'e2fsprogs'
+ 'nspr'
+ 'alsa-lib'
+ 'expat'
+ 'libp11-kit'
+ 'freetype2'
+ 'fontconfig'
+ 'sqlite'
+ 'libx11'
+)
+makedepends=(
+ 'squashfuse'
+)
+options=("!strip")
+source=(
+ "${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/${pkgver}/${_pkgname}-Linux-${CARCH}.AppImage"
+ "LICENSE-${pkgver}::https://raw.githubusercontent.com/ic005k/Knot/${pkgver}/LICENSE"
+ "${pkgname%-bin}.sh"
+)
+sha256sums=('912ad18c9ff3223c4a15891a403a794031b6d9a811e6539a0399348df2489bf8'
+ 'e81172c8f0c194e8fb34edd30b153e60407a094bbf2492abe4e012e6a1ad854a'
+ 'aec1ed1418460a2f4ed06ef6790036b87ea4d36a03ea057de5212302f318cf79')
+build() {
+ sed -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@runname@|${_pkgname}|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
+ chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
+ "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
+ sed -e "s|Exec=${_pkgname}|Exec=${pkgname%-bin}|g" \
+ -e "s|icon|${pkgname%-bin}|g" \
+ -e "s|Application;|Utility|g" \
+ -e "s|Name=${_pkgname}|Name=Android ${_pkgname}|g" \
+ -i "${srcdir}/squashfs-root/default.desktop"
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm755 -d "${pkgdir}/opt/${pkgname%-bin}"
+ cp -r "${srcdir}/squashfs-root/"* "${pkgdir}/opt/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/default.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ install -Dm644 "${srcdir}/squashfs-root/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
+ install -Dm644 "${srcdir}/LICENSE-${pkgver}" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+} \ No newline at end of file
diff --git a/android-knot.sh b/android-knot.sh
new file mode 100644
index 000000000000..9f09e9392083
--- /dev/null
+++ b/android-knot.sh
@@ -0,0 +1,10 @@
+#!/bin/sh
+set -e
+_APPDIR="/opt/@appname@"
+_RUNNAME="${_APPDIR}/@runname@"
+export PATH="${_APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+export QT_PLUGIN_PATH="${_APPDIR}/plugins:$QT_PLUGIN_PATH"
+cd "${_APPDIR}"
+exec "${_RUNNAME}" "$@"
+exit \ No newline at end of file