summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2023-06-10 22:08:41 +0800
committerChih-Hsuan Yen2023-06-10 22:08:41 +0800
commit7cf8c906d65a130fffe503cb7985547fff1e4c8c (patch)
treefe9c890af3de090fa40c0be00d03fb2a8f8ace58
parent09b25fb51992d5f195d0e7c28d87e71c473c2d51 (diff)
downloadaur-7cf8c906d65a130fffe503cb7985547fff1e4c8c.tar.gz
android-ndk: add missing dependencies
See: https://aur.archlinux.org/packages/android-ndk#comment-918630
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD14
2 files changed, 24 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e9c408b1e40..23dc8c67e40a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,28 @@
pkgbase = android-ndk
pkgdesc = Android C/C++ developer kit
pkgver = r25.c
- pkgrel = 1
+ pkgrel = 2
url = https://developer.android.com/ndk/
install = android-ndk.install
arch = x86_64
license = GPL
license = LGPL
license = custom
+ makedepends = bzip2
+ makedepends = libxcrypt-compat
+ makedepends = python
+ makedepends = perl
+ makedepends = libc++
+ depends = bash
depends = glibc
- optdepends = ncurses5-compat-libs: for using gdb
- optdepends = python2: various helper scripts
+ depends = gcc-libs
+ depends = zlib
+ optdepends = ncurses5-compat-libs: for curses module in bundled Python
+ optdepends = bzip2: for bz2 module in bundled Python
+ optdepends = libxcrypt-compat: for crypt module in bundled Python
optdepends = python: various helper scripts
+ optdepends = perl: various helper scripts
+ optdepends = libc++: for some LLVM components
replaces = android-ndk64
options = !strip
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index 615d3de6e8ac..a68552447eb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=android-ndk
pkgver=r25.c
-pkgrel=1
+pkgrel=2
pkgdesc='Android C/C++ developer kit'
arch=('x86_64')
url='https://developer.android.com/ndk/'
@@ -14,11 +14,17 @@ options=('!strip' 'staticlibs')
backup=("etc/profile.d/$pkgname.sh")
install="$pkgname.install"
replaces=('android-ndk64')
-depends=('glibc')
+depends=('bash' 'glibc' 'gcc-libs' 'zlib')
+# makedepends are just for making namcap happy. AUR packages are not added to
+# avoid unneeded efforts
+makedepends=('bzip2' 'libxcrypt-compat' 'python' 'perl' 'libc++')
optdepends=(
- 'ncurses5-compat-libs: for using gdb'
- 'python2: various helper scripts'
+ 'ncurses5-compat-libs: for curses module in bundled Python'
+ 'bzip2: for bz2 module in bundled Python'
+ 'libxcrypt-compat: for crypt module in bundled Python'
'python: various helper scripts'
+ 'perl: various helper scripts'
+ 'libc++: for some LLVM components'
)
source=("$pkgname.sh")
source_x86_64=("https://dl.google.com/android/repository/$pkgname-${pkgver/./}-linux.zip")