summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2019-07-08 09:29:25 +0800
committerlilac2019-07-08 09:29:25 +0800
commitdd01370bf7698e1c54f46db5a4935f01d853f7eb (patch)
treee60d5154bc3d0d33ea8e1a273b06e6c732711f3c
parentd3e8c6422c6846a1c69ee8cd746608c4993c18d4 (diff)
downloadaur-dd01370bf7698e1c54f46db5a4935f01d853f7eb.tar.gz
update by lilac
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aef95e8929d5..c89401a3e621 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = android-ndk
pkgdesc = Android C/C++ developer kit
pkgver = r20
- pkgrel = 1
+ pkgrel = 3
url = https://developer.android.com/ndk/
install = android-ndk.install
arch = x86_64
@@ -9,14 +9,19 @@ pkgbase = android-ndk
license = LGPL
license = custom
depends = glibc
+ optdepends = ncurses5-compat-libs: for using gdb
+ optdepends = python2: various helper scripts
+ optdepends = python: various helper scripts
replaces = android-ndk64
options = !strip
options = staticlibs
backup = etc/profile.d/android-ndk.sh
source = android-ndk.sh
sha1sums = 2479a8d74428eb651ad2b9772ad655d7a90af410
+ sha256sums = 2068618bc3e99149310f544be5d639ae183dc767d5a7157a07d8e024417b6017
source_x86_64 = https://dl.google.com/android/repository/android-ndk-r20-linux-x86_64.zip
sha1sums_x86_64 = 8665fc84a1b1f0d6ab3b5fdd1e30200cc7b9adff
+ sha256sums_x86_64 = 57435158f109162f41f2f43d5563d2164e4d5d0364783a9a6fab3ef12cb06ce0
pkgname = android-ndk
diff --git a/PKGBUILD b/PKGBUILD
index 04b78b6efd1c..321440ae2885 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,26 +5,32 @@
pkgname=android-ndk
pkgver=r20
-pkgrel=1
+pkgrel=3
pkgdesc='Android C/C++ developer kit'
arch=('x86_64')
url='https://developer.android.com/ndk/'
license=('GPL' 'LGPL' 'custom')
options=('!strip' 'staticlibs')
-backup=('etc/profile.d/android-ndk.sh')
+backup=("etc/profile.d/$pkgname.sh")
install="$pkgname.install"
replaces=('android-ndk64')
depends=('glibc')
-source=('android-ndk.sh')
+optdepends=(
+ 'ncurses5-compat-libs: for using gdb'
+ 'python2: various helper scripts'
+ 'python: various helper scripts'
+)
+source=("$pkgname.sh")
source_x86_64=("https://dl.google.com/android/repository/$pkgname-${pkgver/./}-linux-x86_64.zip")
+# SHA1 sums is kept to follow upstream releases https://github.com/android-ndk/ndk/issues/673
sha1sums=('2479a8d74428eb651ad2b9772ad655d7a90af410')
sha1sums_x86_64=('8665fc84a1b1f0d6ab3b5fdd1e30200cc7b9adff')
+sha256sums=('2068618bc3e99149310f544be5d639ae183dc767d5a7157a07d8e024417b6017')
+sha256sums_x86_64=('57435158f109162f41f2f43d5563d2164e4d5d0364783a9a6fab3ef12cb06ce0')
package() {
install -Ddm755 "$pkgdir/opt"
mv "$pkgname-${pkgver/./}" "$pkgdir/opt/$pkgname"
- install -Dm755 android-ndk.sh "$pkgdir/etc/profile.d/android-ndk.sh"
+ install -Dm644 $pkgname.sh -t "$pkgdir/etc/profile.d/"
}
-
-# vim: ts=2 sw=2 et: