summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2016-04-06 11:45:25 +0200
committerAlexander F Rødseth2016-04-06 11:45:25 +0200
commitfbbb5fe0c34bf8575c7f479b1cd14bbb17392c42 (patch)
treea93a018a9ea906cffd90fedc9d0a8281558c7f1e
parenta963abb2dbf3a2c68d38053f08281b3d0ef2418c (diff)
downloadaur-fbbb5fe0c34bf8575c7f479b1cd14bbb17392c42.tar.gz
Version bump
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50e41a485b01..d81de56dc76d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
-# Generated by makepkg 4.2.1
-# Tue Jun 30 15:32:59 UTC 2015
+# Generated by mksrcinfo v8
+# Sat Mar 12 11:16:34 UTC 2016
pkgbase = android-ndk
pkgdesc = Android C/C++ developer kit
- pkgver = r10e
+ pkgver = r11
pkgrel = 1
url = https://developer.android.com/ndk/
install = android-ndk.install
arch = x86_64
- arch = i686
license = GPL
license = LGPL
license = custom
+ depends = ncurses5-compat-libs
provides = android-ndk
replaces = android-ndk32
replaces = android-ndk64
@@ -18,11 +18,9 @@ pkgbase = android-ndk
options = staticlibs
backup = etc/profile.d/android-ndk.sh
source = android-ndk.sh
- md5sums = 372f74400bfa061642c4b4175f2ddb48
- source_x86_64 = android-ndk_x86_64.bin::http://dl.google.com/android/ndk/android-ndk-r10e-linux-x86_64.bin
- md5sums_x86_64 = 19af543b068bdb7f27787c2bc69aba7f
- source_i686 = android-ndk_i686.bin::http://dl.google.com/android/ndk/android-ndk-r10e-linux-x86.bin
- md5sums_i686 = c3edd3273029da1cbd2f62c48249e978
+ source = http://dl.google.com/android/repository/android-ndk-r11-linux-x86_64.zip
+ sha256sums = 5bc58ccd7e7de03c9656ca8f13fb9bf9dff2eeee31a2670ce04a4b97be73dc95
+ sha256sums = bfc80b786eb0cef271089602399c91979e9ba5727247c3dc6548cc21c6052de0
pkgname = android-ndk
diff --git a/PKGBUILD b/PKGBUILD
index 15af5619b495..cd1027169b79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
-# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
# Contributor: Daniel Micay <danielmicay@gmail.com>
# Contributor: frownlee <florez.brownlee@gmail.com>
pkgname=android-ndk
-pkgver=r10e
+pkgver=r11
pkgrel=1
pkgdesc='Android C/C++ developer kit'
-arch=('x86_64' 'i686')
+arch=('x86_64')
url='https://developer.android.com/ndk/'
license=('GPL' 'LGPL' 'custom')
options=('!strip' 'staticlibs')
@@ -14,16 +14,14 @@ backup=('etc/profile.d/android-ndk.sh')
install="$pkgname.install"
provides=('android-ndk')
replaces=('android-ndk32' 'android-ndk64')
-source=('android-ndk.sh')
-source_x86_64=("${pkgname}_x86_64.bin::http://dl.google.com/android/ndk/${pkgname}-$pkgver-linux-x86_64.bin")
-source_i686=("${pkgname}_i686.bin::http://dl.google.com/android/ndk/${pkgname}-$pkgver-linux-x86.bin")
-md5sums=('372f74400bfa061642c4b4175f2ddb48')
-md5sums_x86_64=('19af543b068bdb7f27787c2bc69aba7f')
-md5sums_i686=('c3edd3273029da1cbd2f62c48249e978')
+depends=('ncurses5-compat-libs')
+source=('android-ndk.sh' "http://dl.google.com/android/repository/${pkgname}-$pkgver-linux-x86_64.zip")
+sha256sums=('5bc58ccd7e7de03c9656ca8f13fb9bf9dff2eeee31a2670ce04a4b97be73dc95'
+ 'bfc80b786eb0cef271089602399c91979e9ba5727247c3dc6548cc21c6052de0')
prepare() {
- chmod +x ${pkgname}_$CARCH.bin
- ./${pkgname}_$CARCH.bin
+ # Weirdest directory name, inside a zip file. What were they smoking?
+ mv "$pkgname-$pkgver-linux-x86_64.tar.bz2/" "$pkgname-$pkgver"
}
package() {