summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranck Lucien Duriez2018-08-28 16:15:56 +0200
committerFranck Lucien Duriez2018-08-28 17:54:04 +0200
commit0a64296ea210c1e42758679c3372a901d326050c (patch)
treef2c474f5784b18435152a30b4c2a131dbc8f47de
downloadaur-0a64296ea210c1e42758679c3372a901d326050c.tar.gz
First commit
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
-rw-r--r--android-ndk.install6
-rw-r--r--android-ndk.sh2
5 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e671fe596bd5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = android-ndk-14b
+ pkgdesc = Android C/C++ developer kit
+ pkgver = r14_b
+ pkgrel = 1
+ url = https://developer.android.com/ndk/
+ install = android-ndk.install
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ license = custom
+ depends = ncurses5-compat-libs
+ provides = android-ndk
+ conflicts = android-ndk
+ replaces = android-ndk64
+ options = !strip
+ options = staticlibs
+ backup = etc/profile.d/android-ndk.sh
+ source = android-ndk.sh
+ source = http://dl.google.com/android/repository/android-ndk-r14b-linux-x86_64.zip
+ sha256sums = 5bc58ccd7e7de03c9656ca8f13fb9bf9dff2eeee31a2670ce04a4b97be73dc95
+ sha256sums = 0ecc2017802924cf81fffc0f51d342e3e69de6343da892ac9fa1cd79bc106024
+
+pkgname = android-ndk-14b
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..288dd18d486d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.xz
+*.zip
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bec82119dbd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Oscar Morante <spacepluk@gmail.com>
+
+pkgname=android-ndk-14b
+_pkg=android-ndk
+pkgver=r14_b
+pkgrel=1
+pkgdesc='Android C/C++ developer kit'
+arch=('x86_64')
+url='https://developer.android.com/ndk/'
+license=('GPL' 'LGPL' 'custom')
+options=('!strip' 'staticlibs')
+backup=('etc/profile.d/android-ndk.sh')
+install="android-ndk.install"
+provides=('android-ndk')
+conflicts=('android-ndk')
+replaces=('android-ndk64')
+depends=('ncurses5-compat-libs')
+source=('android-ndk.sh' "http://dl.google.com/android/repository/$_pkg-${pkgver/_/}-linux-x86_64.zip")
+sha256sums=('5bc58ccd7e7de03c9656ca8f13fb9bf9dff2eeee31a2670ce04a4b97be73dc95'
+ '0ecc2017802924cf81fffc0f51d342e3e69de6343da892ac9fa1cd79bc106024')
+
+package() {
+ install -d "$pkgdir/opt"
+ mv "$_pkg-${pkgver/_/}" "$pkgdir/opt/$_pkg"
+ install -Dm755 android-ndk.sh "$pkgdir/etc/profile.d/android-ndk.sh"
+
+ # Fix permissions
+ chmod -R o=g "$pkgdir/opt/$_pkg"
+ find "$pkgdir/opt/$_pkg" -perm 744 -exec chmod 755 {} +
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/android-ndk.install b/android-ndk.install
new file mode 100644
index 000000000000..9d5e400344f0
--- /dev/null
+++ b/android-ndk.install
@@ -0,0 +1,6 @@
+post_install() {
+ echo 'Source /etc/profile.d/android-ndk.sh or login again to add the'
+ echo 'Android NDK tools to your path.'
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/android-ndk.sh b/android-ndk.sh
new file mode 100644
index 000000000000..8bc388f19116
--- /dev/null
+++ b/android-ndk.sh
@@ -0,0 +1,2 @@
+export PATH=$PATH:/opt/android-ndk
+export ANDROID_NDK=/opt/android-ndk