summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Morante2018-12-17 10:14:49 +0200
committerOscar Morante2018-12-17 10:15:34 +0200
commit337b36e7992fca7ae96f241d5a19d6aa781ec047 (patch)
tree6f80326a4a0475a7bad8064cd8875613ec105c0a
downloadaur-337b36e7992fca7ae96f241d5a19d6aa781ec047.tar.gz
first commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD32
-rw-r--r--android-ndk.install6
-rw-r--r--android-ndk.sh3
4 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d33f3d8aaa57
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = android-ndk-16b
+ pkgdesc = Android C/C++ developer kit
+ pkgver = r16_b
+ pkgrel = 1
+ url = https://developer.android.com/ndk/
+ install = android-ndk.install
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ license = custom
+ depends = ncurses5-compat-libs
+ provides = android-ndk
+ conflicts = android-ndk
+ replaces = android-ndk64
+ options = !strip
+ options = staticlibs
+ backup = etc/profile.d/android-ndk.sh
+ source = android-ndk.sh
+ source = http://dl.google.com/android/repository/android-ndk-r16b-linux-x86_64.zip
+ sha256sums = 5bc58ccd7e7de03c9656ca8f13fb9bf9dff2eeee31a2670ce04a4b97be73dc95
+ sha256sums = bcdea4f5353773b2ffa85b5a9a2ae35544ce88ec5b507301d8cf6a76b765d901
+
+pkgname = android-ndk-16b
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f05005b22b43
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Oscar Morante <spacepluk@gmail.com>
+
+pkgname=android-ndk-16b
+_pkg=android-ndk
+pkgver=r16_b
+pkgrel=1
+pkgdesc='Android C/C++ developer kit'
+arch=('x86_64')
+url='https://developer.android.com/ndk/'
+license=('GPL' 'LGPL' 'custom')
+options=('!strip' 'staticlibs')
+backup=('etc/profile.d/android-ndk.sh')
+install="android-ndk.install"
+provides=('android-ndk')
+conflicts=('android-ndk')
+replaces=('android-ndk64')
+depends=('ncurses5-compat-libs')
+source=('android-ndk.sh' "http://dl.google.com/android/repository/$_pkg-${pkgver/_/}-linux-x86_64.zip")
+sha256sums=('5bc58ccd7e7de03c9656ca8f13fb9bf9dff2eeee31a2670ce04a4b97be73dc95'
+ 'bcdea4f5353773b2ffa85b5a9a2ae35544ce88ec5b507301d8cf6a76b765d901')
+
+package() {
+ install -d "$pkgdir/opt"
+ mv "$_pkg-${pkgver/_/}" "$pkgdir/opt/$_pkg"
+ install -Dm755 android-ndk.sh "$pkgdir/etc/profile.d/android-ndk.sh"
+
+ # Fix permissions
+ chmod -R o=g "$pkgdir/opt/$_pkg"
+ find "$pkgdir/opt/$_pkg" -perm 744 -exec chmod 755 {} +
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/android-ndk.install b/android-ndk.install
new file mode 100644
index 000000000000..9d5e400344f0
--- /dev/null
+++ b/android-ndk.install
@@ -0,0 +1,6 @@
+post_install() {
+ echo 'Source /etc/profile.d/android-ndk.sh or login again to add the'
+ echo 'Android NDK tools to your path.'
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/android-ndk.sh b/android-ndk.sh
new file mode 100644
index 000000000000..cd32ab370820
--- /dev/null
+++ b/android-ndk.sh
@@ -0,0 +1,3 @@
+export PATH=$PATH:/opt/android-ndk
+export ANDROID_NDK=/opt/android-ndk
+export ANDROID_NDK_HOME=/opt/android-ndk