summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2018-08-24 11:53:37 +0800
committerChih-Hsuan Yen2018-08-24 11:53:37 +0800
commit011301fc938ee1118a5fb00ccdb1fa508b361f7d (patch)
treecf5e6448912849b1872688dd1420c623546fc8b4
parent91bcef4c8f2bdd6b8ab910b504f073ba21375cce (diff)
downloadaur-011301fc938ee1118a5fb00ccdb1fa508b361f7d.tar.gz
misc changes
* Address https://lists.archlinux.org/pipermail/aur-general/2018-August/034249.html * Make it consistent with android-ndk-beta
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
-rw-r--r--android-ndk.sh2
3 files changed, 20 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7ee1f0314a5..ad5968be18c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,15 +9,17 @@ pkgbase = android-ndk
license = LGPL
license = custom
depends = ncurses5-compat-libs
- provides = android-ndk
+ optdepends = python: various helper scripts
replaces = android-ndk64
options = !strip
options = staticlibs
backup = etc/profile.d/android-ndk.sh
source = android-ndk.sh
- source = https://dl.google.com/android/repository/android-ndk-r17b-linux-x86_64.zip
- sha1sums = 234f2814d10de08499032fd6772d701d9160433a
- sha1sums = dd5762ee7ef4995ad04fe0c45a608c344d99ca9f
+ sha1sums = 2479a8d74428eb651ad2b9772ad655d7a90af410
+ sha256sums = 2068618bc3e99149310f544be5d639ae183dc767d5a7157a07d8e024417b6017
+ source_x86_64 = https://dl.google.com/android/repository/android-ndk-r17b-linux-x86_64.zip
+ sha1sums_x86_64 = dd5762ee7ef4995ad04fe0c45a608c344d99ca9f
+ sha256sums_x86_64 = 5dfbbdc2d3ba859fed90d0e978af87c71a91a5be1f6e1c40ba697503d48ccecd
pkgname = android-ndk
diff --git a/PKGBUILD b/PKGBUILD
index 50577a7fd986..8c2919edc007 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,24 +11,26 @@ arch=('x86_64')
url='https://developer.android.com/ndk/'
license=('GPL' 'LGPL' 'custom')
options=('!strip' 'staticlibs')
-backup=('etc/profile.d/android-ndk.sh')
+backup=("etc/profile.d/$pkgname.sh")
install="$pkgname.install"
-provides=('android-ndk')
replaces=('android-ndk64')
depends=('ncurses5-compat-libs')
-source=('android-ndk.sh' "https://dl.google.com/android/repository/${pkgname}-${pkgver/./}-linux-x86_64.zip")
-sha1sums=('234f2814d10de08499032fd6772d701d9160433a'
- 'dd5762ee7ef4995ad04fe0c45a608c344d99ca9f')
+optdepends=(
+ 'python: various helper scripts'
+)
+source=("$pkgname.sh")
+source_x86_64=("https://dl.google.com/android/repository/${pkgname}-${pkgver/./}-linux-x86_64.zip")
+# SHA1 sums is kept to follow upstream releases https://github.com/android-ndk/ndk/issues/673
+sha1sums=('2479a8d74428eb651ad2b9772ad655d7a90af410')
+sha1sums_x86_64=('dd5762ee7ef4995ad04fe0c45a608c344d99ca9f')
+sha256sums=('2068618bc3e99149310f544be5d639ae183dc767d5a7157a07d8e024417b6017')
+sha256sums_x86_64=('5dfbbdc2d3ba859fed90d0e978af87c71a91a5be1f6e1c40ba697503d48ccecd')
package() {
install -d "$pkgdir/opt"
mv "$pkgname-${pkgver/./}" "$pkgdir/opt/$pkgname"
- install -Dm755 android-ndk.sh "$pkgdir/etc/profile.d/android-ndk.sh"
-
- # Fix broken permissions
- chmod -R o=g "$pkgdir/opt/$pkgname"
- find "$pkgdir/opt/$pkgname" -perm 744 -exec chmod 755 {} +
+ install -Dm755 $pkgname.sh "$pkgdir/etc/profile.d/$pkgname.sh"
}
-# vim: ts=2 sw=2 et:
+# vim: set ts=2 sw=2 et ft=sh:
diff --git a/android-ndk.sh b/android-ndk.sh
index 9e03f544a06e..85e45617a9ef 100644
--- a/android-ndk.sh
+++ b/android-ndk.sh
@@ -1,4 +1,4 @@
-export PATH=$PATH:/opt/android-ndk
+export PATH="$PATH:/opt/android-ndk"
export ANDROID_NDK=/opt/android-ndk
# Some programs such as gradle ask this as well:
export ANDROID_NDK_HOME=/opt/android-ndk