summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2016-12-25 17:16:32 +0800
committerYen Chi Hsuan2016-12-25 17:16:32 +0800
commit7e6162b2714448ae3eef9a1e1df84b45844823e5 (patch)
treef50d12ff108b0f38b0d05e7ddec769be8c7f48f7
downloadaur-7e6162b2714448ae3eef9a1e1df84b45844823e5.tar.gz
New package
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD33
-rw-r--r--android-ndk-beta.install6
-rw-r--r--android-ndk-beta.sh2
4 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0655ac45cab4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Sun Dec 25 09:09:54 UTC 2016
+pkgbase = android-ndk-beta
+ pkgdesc = Android C/C++ developer kit (beta)
+ pkgver = r14_beta1
+ pkgrel = 1
+ url = https://developer.android.com/ndk/
+ install = android-ndk-beta.install
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ license = custom
+ depends = ncurses5-compat-libs
+ options = !strip
+ options = staticlibs
+ backup = etc/profile.d/android-ndk-beta.sh
+ source = android-ndk-beta.sh
+ source = https://dl.google.com/android/repository/android-ndk-r14-beta1-linux-x86_64.zip
+ sha256sums = a6b0dae2d8016af6b731bc45a78489cdb3aab5d332c0395188887ee369aea5f5
+ sha256sums = 3b5c1ebe736c0c4726e746c20f96ba31df3cc8cbbedf69a3d1530987c8723f6e
+
+pkgname = android-ndk-beta
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91e45b60fe62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Yen Chi Hsuan <yan12125@gmail.com>
+# Contributor: Alexander F Rødseth <xyproto@archlinux.org>
+# Contributor: Daniel Micay <danielmicay@gmail.com>
+# Contributor: frownlee <florez.brownlee@gmail.com>
+
+pkgname=android-ndk-beta
+_pkgname=${pkgname/-beta*/}
+pkgver=r14_beta1
+pkgrel=1
+pkgdesc='Android C/C++ developer kit (beta)'
+arch=('x86_64')
+url='https://developer.android.com/ndk/'
+license=('GPL' 'LGPL' 'custom')
+options=('!strip' 'staticlibs')
+backup=('etc/profile.d/android-ndk-beta.sh')
+install="$pkgname.install"
+depends=('ncurses5-compat-libs')
+source=('android-ndk-beta.sh' "https://dl.google.com/android/repository/${_pkgname}-${pkgver/_/-}-linux-x86_64.zip")
+sha256sums=('a6b0dae2d8016af6b731bc45a78489cdb3aab5d332c0395188887ee369aea5f5'
+ '3b5c1ebe736c0c4726e746c20f96ba31df3cc8cbbedf69a3d1530987c8723f6e')
+
+package() {
+ install -d "$pkgdir/opt"
+ mv "$_pkgname-${pkgver/_/-}" "$pkgdir/opt/$pkgname"
+
+ install -Dm755 $pkgname.sh "$pkgdir/etc/profile.d/$pkgname.sh"
+
+ # Fix broken permissions
+ chmod -R o=g "$pkgdir/opt/$pkgname"
+ find "$pkgdir/opt/$pkgname" -perm 744 -exec chmod 755 {} +
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/android-ndk-beta.install b/android-ndk-beta.install
new file mode 100644
index 000000000000..8557b24569c5
--- /dev/null
+++ b/android-ndk-beta.install
@@ -0,0 +1,6 @@
+post_install() {
+ echo 'Source /etc/profile.d/android-ndk-beta.sh or login again to add the'
+ echo 'Android NDK tools to your path.'
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/android-ndk-beta.sh b/android-ndk-beta.sh
new file mode 100644
index 000000000000..60737fb593a3
--- /dev/null
+++ b/android-ndk-beta.sh
@@ -0,0 +1,2 @@
+export PATH=$PATH:/opt/android-ndk-beta
+export ANDROID_NDK=/opt/android-ndk-beta