summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKppqju772021-12-09 16:25:04 +0100
committerKppqju772021-12-09 16:25:04 +0100
commitd01c197ac874ecef3c6a9771b119e0e500aee652 (patch)
tree8651ea79e47ae3a520b413b669a796912a217763
parent4849df955a4c5eecf8f0e734b4594675337b09af (diff)
downloadaur-d01c197ac874ecef3c6a9771b119e0e500aee652.tar.gz
Update to API 32
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD11
-rw-r--r--package.xml4
3 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac1a44c40b79..7ca62e8d6a24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = android-platform
pkgdesc = Android SDK Platform, latest API
- pkgver = 31_r01
+ pkgver = 32_r01
pkgrel = 1
url = http://developer.android.com/sdk/index.html
arch = any
license = custom
- provides = android-platform-31
- conflicts = android-platform-31
+ provides = android-platform-32
+ conflicts = android-platform-32
options = !strip
- source = https://dl.google.com/android/repository/platform-31_r01.zip
+ source = https://dl.google.com/android/repository/platform-32_r01.zip
source = package.xml
- sha1sums = ca5bcaa565cb37e9d287051d6dd0e49a5426ec29
- sha1sums = 282839150fb5472b8784c23943dde146ac5bb116
- sha384sums = 0a7b03eb59df99d0be5acc9c3c43c1d575afeb069bca8c6aee117820fca68d1b89da133fd6fc64d74542045efb48a501
- sha384sums = e84e72953a3a6b082563b7218b43c88915e8d0c8b55a645829ab59e95521798a57d50889348c18a837050c60862023c7
+ sha256sums = 01d8da1c900e70fcf5da39767d5444e39928935b1a5927055ce749fc348ca7ae
+ sha256sums = 6cce8c9cf729b4bfb6f1509617d6cc1f68fc0d5586ea30fc5d344426d6832a92
pkgname = android-platform
depends = android-sdk
diff --git a/PKGBUILD b/PKGBUILD
index dee6b30b552e..8dcafe2a8f8c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# Contributor: Jakub Schmidtke
pkgname=android-platform
-_apilevel=31
+_apilevel=32
_rev=r01
pkgver=${_apilevel}_${_rev}
pkgrel=1
@@ -20,10 +20,8 @@ conflicts=("${pkgname}-${_apilevel}")
options=('!strip')
source=("https://dl.google.com/android/repository/platform-${_apilevel}_${_rev}.zip"
"package.xml")
-sha1sums=('ca5bcaa565cb37e9d287051d6dd0e49a5426ec29'
- '282839150fb5472b8784c23943dde146ac5bb116')
-sha384sums=('0a7b03eb59df99d0be5acc9c3c43c1d575afeb069bca8c6aee117820fca68d1b89da133fd6fc64d74542045efb48a501'
- 'e84e72953a3a6b082563b7218b43c88915e8d0c8b55a645829ab59e95521798a57d50889348c18a837050c60862023c7')
+sha256sums=('01d8da1c900e70fcf5da39767d5444e39928935b1a5927055ce749fc348ca7ae'
+ '6cce8c9cf729b4bfb6f1509617d6cc1f68fc0d5586ea30fc5d344426d6832a92')
package() {
depends=('android-sdk' 'android-sdk-platform-tools')
@@ -35,5 +33,8 @@ package() {
install -D -m 644 "package.xml" "${pkgdir}/usr/share/licenses/${pkgname}/package.xml"
+ ln -s "/usr/share/licenses/${pkgname}/package.xml" \
+ "${pkgdir}/opt/android-sdk/platforms/android-${_apilevel}/"
+
chmod -R ugo+rX "${pkgdir}/opt"
}
diff --git a/package.xml b/package.xml
index 87632f903c88..b7db1f4fa66b 100644
--- a/package.xml
+++ b/package.xml
@@ -1,4 +1,4 @@
-<?xml version="1.0" encoding="UTF-8" standalone="yes"?><ns2:repository xmlns:ns2="http://schemas.android.com/repository/android/common/01" xmlns:ns3="http://schemas.android.com/repository/android/generic/01" xmlns:ns4="http://schemas.android.com/sdk/android/repo/addon2/01" xmlns:ns5="http://schemas.android.com/sdk/android/repo/repository2/01" xmlns:ns6="http://schemas.android.com/sdk/android/repo/sys-img2/01"><license id="android-sdk-license" type="text">Terms and Conditions
+<?xml version="1.0" encoding="UTF-8" standalone="yes"?><ns2:repository xmlns:ns2="http://schemas.android.com/repository/android/common/02" xmlns:ns3="http://schemas.android.com/repository/android/common/01" xmlns:ns4="http://schemas.android.com/repository/android/generic/01" xmlns:ns5="http://schemas.android.com/repository/android/generic/02" xmlns:ns6="http://schemas.android.com/sdk/android/repo/addon2/01" xmlns:ns7="http://schemas.android.com/sdk/android/repo/addon2/02" xmlns:ns8="http://schemas.android.com/sdk/android/repo/repository2/01" xmlns:ns9="http://schemas.android.com/sdk/android/repo/repository2/02" xmlns:ns10="http://schemas.android.com/sdk/android/repo/sys-img2/02" xmlns:ns11="http://schemas.android.com/sdk/android/repo/sys-img2/01"><license id="android-sdk-license" type="text">Terms and Conditions
This is the Android Software Development Kit License Agreement
@@ -138,4 +138,4 @@ This is the Android Software Development Kit License Agreement
14.7 The License Agreement, and your relationship with Google under the License Agreement, shall be governed by the laws of the State of California without regard to its conflict of laws provisions. You and Google agree to submit to the exclusive jurisdiction of the courts located within the county of Santa Clara, California to resolve any legal matter arising from the License Agreement. Notwithstanding this, you agree that Google shall still be allowed to apply for injunctive remedies (or an equivalent type of urgent legal relief) in any jurisdiction.
-January 16, 2019</license><localPackage path="platforms;android-31" obsolete="false"><type-details xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:type="ns5:platformDetailsType"><api-level>31</api-level><codename></codename><layoutlib api="15"/></type-details><revision><major>1</major></revision><display-name>Android SDK Platform 31</display-name><uses-license ref="android-sdk-license"/></localPackage></ns2:repository> \ No newline at end of file
+January 16, 2019</license><localPackage path="platforms;android-32" obsolete="false"><type-details xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:type="ns9:platformDetailsType"><api-level>32</api-level><codename></codename><layoutlib api="15"/></type-details><revision><major>1</major></revision><display-name>Android SDK Platform 32</display-name><uses-license ref="android-sdk-license"/></localPackage></ns2:repository> \ No newline at end of file