summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2020-06-15 21:37:22 +0200
committerMuflone2020-06-15 21:37:22 +0200
commit9294a6225199ba979d611636b48ae9d285dc9bd2 (patch)
tree532b05fa696634eccf3cb2cc92ea691efcacd71a
downloadaur-9294a6225199ba979d611636b48ae9d285dc9bd2.tar.gz
New package android-platform-30 30_r01-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1016f2678c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = android-platform-30
+ pkgdesc = Android SDK Platform, latest API
+ pkgver = 30_r01
+ pkgrel = 1
+ url = http://developer.android.com/sdk/index.html
+ arch = any
+ license = custom
+ depends = android-sdk
+ depends = android-sdk-platform-tools
+ provides = android-platform-30-30
+ conflicts = android-platform-30-30
+ options = !strip
+ source = https://dl-ssl.google.com/android/repository/platform-30_r01.zip
+ sha1sums = 63aed027a1aa272ff894545af8106255e84f2140
+ sha384sums = c3d9fe96b6d9a36f91a123689465f7c33d4ff2035b2de7510f596ace9f4f1f15135eb8f26b3713df6e55214d9a482723
+
+pkgname = android-platform-30
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c13553fa0d3d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+# Contributors: goetzc, Skycoder42
+# Contributors: lestb, Philipp Wolfer, Joel Pedraza, Jakub Schmidtke
+
+pkgname=android-platform-30
+_apilevel=30
+_rev=r01
+pkgver=${_apilevel}_${_rev}
+pkgrel=1
+pkgdesc="Android SDK Platform, latest API"
+arch=('any')
+url="http://developer.android.com/sdk/index.html"
+license=('custom')
+depends=('android-sdk' 'android-sdk-platform-tools')
+provides=("${pkgname}-${_apilevel}")
+conflicts=("${pkgname}-${_apilevel}")
+options=('!strip')
+source=("https://dl-ssl.google.com/android/repository/platform-${_apilevel}_${_rev}.zip")
+sha1sums=('63aed027a1aa272ff894545af8106255e84f2140')
+sha384sums=('c3d9fe96b6d9a36f91a123689465f7c33d4ff2035b2de7510f596ace9f4f1f15135eb8f26b3713df6e55214d9a482723')
+
+package() {
+ mkdir -p "${pkgdir}/opt/android-sdk/platforms/"
+ find "${srcdir}" -maxdepth 1 -mindepth 1 -type d | grep -P 'android-[0-9]+(\.[0-9]*)*$' | while read directory; do
+ mv "${directory}" "${pkgdir}/opt/android-sdk/platforms/android-${_apilevel}"
+ done
+
+ chmod -R ugo+rX "${pkgdir}/opt"
+}