summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2017-03-05 12:23:14 -0300
committerGonzalo Exequiel Pedone2017-03-05 12:23:14 -0300
commitcff1875f36fe63974ead359b88185fee533bce34 (patch)
treeb446595d6e3f0a974f0dd018f9995a29b9aa6b46
parentbcfc2fd18bd1433f64cc854b296acedf0c333ef7 (diff)
downloadaur-cff1875f36fe63974ead359b88185fee533bce34.tar.gz
Package updated.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD23
-rw-r--r--imageformats.pro.patch12
3 files changed, 12 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36c48db80fc3..def42127c66b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# vie ene 27 18:36:37 UTC 2017
+# dom mar 5 15:23:13 UTC 2017
pkgbase = android-qt5-mips
pkgdesc = Qt 5 for Android
pkgver = 5.8.0
- pkgrel = 2
+ pkgrel = 3
url = https://www.qt.io
arch = i686
arch = x86_64
@@ -27,10 +27,8 @@ pkgbase = android-qt5-mips
depends = android-sdk-platform-tools
source = http://download.qt-project.org/official_releases/qt/5.8/5.8.0/single/qt-everywhere-opensource-src-5.8.0.tar.xz
source = JavaScriptCore.pri.patch
- source = imageformats.pro.patch
sha256sums = 0f4c54386d3dbac0606a936a7145cebb7b94b0ca2d29bc001ea49642984824b6
sha256sums = 133dad6c8d0bedaa5d561be26b2f7185e671900c50d11476ecb2e2ef6792d455
- sha256sums = 943e8c03dc2218250f75cec3b663d90e6bb98d9b64b9f12b01713c284e5e4673
pkgname = android-qt5-mips
diff --git a/PKGBUILD b/PKGBUILD
index 7ed07e018d7a..6e04b42ef453 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,8 @@
android_arch=mips
_pkgname=android-qt5
pkgname=${_pkgname}-${android_arch}
-_pkgver=5.8
-pkgver=${_pkgver}.0
-pkgrel=2
+pkgver=5.8.0
+pkgrel=3
pkgdesc="Qt 5 for Android"
arch=('i686' 'x86_64')
url='https://www.qt.io'
@@ -49,22 +48,16 @@ case "$android_arch" in
esac
_pkgfqn="qt-everywhere-opensource-src-${pkgver}"
-source=("http://download.qt-project.org/official_releases/qt/${_pkgver}/${pkgver}/single/${_pkgfqn}.tar.xz"
- "JavaScriptCore.pri.patch"
- "imageformats.pro.patch")
+source=("http://download.qt-project.org/official_releases/qt/${pkgver:0:3}/${pkgver}/single/${_pkgfqn}.tar.xz"
+ "JavaScriptCore.pri.patch")
sha256sums=('0f4c54386d3dbac0606a936a7145cebb7b94b0ca2d29bc001ea49642984824b6'
- '133dad6c8d0bedaa5d561be26b2f7185e671900c50d11476ecb2e2ef6792d455'
- '943e8c03dc2218250f75cec3b663d90e6bb98d9b64b9f12b01713c284e5e4673')
+ '133dad6c8d0bedaa5d561be26b2f7185e671900c50d11476ecb2e2ef6792d455')
prepare() {
cd ${_pkgfqn}
# Platform specific patches.
case "$android_arch" in
- arm64-v8a)
- # Disable WebP image format.
- patch -Np1 -i "../imageformats.pro.patch"
- ;;
armeabi)
# Disable JIT.
patch -Np1 -i "../JavaScriptCore.pri.patch"
@@ -78,6 +71,10 @@ get_last() {
ls $1 | sort -V | tail -n 1
}
+get_last_platform() {
+ ls $1 | grep 'android-' | sort -V | tail -n 1
+}
+
build() {
cd ${_pkgfqn}
@@ -104,7 +101,7 @@ build() {
export ANDROID_API_VERSION=$(get_last ${ANDROID_SDK_ROOT}/platforms)
export PYTHON=/usr/bin/python2
- ndkPlatform=$(get_last ${ANDROID_NDK_ROOT}/platforms)
+ ndkPlatform=$(get_last_platform ${ANDROID_NDK_ROOT}/platforms)
_pref=/opt/${_pkgname}/${pkgver}/${android_arch}
configue_opts="
diff --git a/imageformats.pro.patch b/imageformats.pro.patch
deleted file mode 100644
index 4aa248da3462..000000000000
--- a/imageformats.pro.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/qtimageformats/src/plugins/imageformats/imageformats.pro 2016-02-02 09:12:49.000000000 -0300
-+++ b/qtimageformats/src/plugins/imageformats/imageformats.pro 2016-03-19 18:23:51.538810498 -0300
-@@ -4,8 +4,7 @@
- icns \
- tga \
- tiff \
-- wbmp \
-- webp
-+ wbmp
-
- config_jasper: SUBDIRS += jp2
- config_libmng: SUBDIRS += mng