summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2018-05-27 11:44:45 -0300
committerGonzalo Exequiel Pedone2018-05-27 11:44:45 -0300
commit16b13c3611fdf511aa5cc7d1635bdce89854804e (patch)
tree223508a4e52b8488919d32a2f34bb418358f68d5
parentcc6aa5f235ba0a5b76d7046e380c0d6823825735 (diff)
downloadaur-16b13c3611fdf511aa5cc7d1635bdce89854804e.tar.gz
Package updated to Qt 5.11.0. Minimum platform appy is now set to 21 (Android 5.0 Lollipop) for all platforms. Removed unnecessary patches.
-rw-r--r--.SRCINFO16
-rw-r--r--JavaScript.Platform.h.patch11
-rw-r--r--JavaScriptCore.pri.patch10
-rw-r--r--PKGBUILD72
-rw-r--r--geoservices.pro.patch12
5 files changed, 20 insertions, 101 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ecda77d8856..6d8673adcc7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# jue feb 15 00:04:51 UTC 2018
+# dom may 27 14:37:07 UTC 2018
pkgbase = android-qt5-x86
pkgdesc = Qt 5 for Android
- pkgver = 5.10.1
+ pkgver = 5.11.0
pkgrel = 1
url = https://www.qt.io
arch = x86_64
@@ -20,7 +20,7 @@ pkgbase = android-qt5-x86
depends = java-runtime-headless>=7
depends = apache-ant
depends = android-ndk
- depends = android-platform-16
+ depends = android-platform-21
depends = android-sdk
depends = android-sdk-build-tools
depends = android-sdk-platform-tools
@@ -30,14 +30,8 @@ pkgbase = android-qt5-x86
options = !buildflags
options = staticlibs
options = !emptydirs
- source = http://download.qt-project.org/official_releases/qt/5.10/5.10.1/single/qt-everywhere-src-5.10.1.tar.xz
- source = geoservices.pro.patch
- source = JavaScriptCore.pri.patch
- source = JavaScript.Platform.h.patch
- md5sums = 7e167b9617e7bd64012daaacb85477af
- md5sums = de535e2ce98e9f75e9ec0ed1c52a2647
- md5sums = d0b3bb4de8a44520c2923e14a8b4f9f1
- md5sums = 4c9bbe21230e34fa07c2cbd5119ceda9
+ source = http://download.qt-project.org/official_releases/qt/5.11/5.11.0/single/qt-everywhere-src-5.11.0.tar.xz
+ md5sums = 68b7c9dd5c5df84b5c82730474c4c1f3
pkgname = android-qt5-x86
diff --git a/JavaScript.Platform.h.patch b/JavaScript.Platform.h.patch
deleted file mode 100644
index eace21d97410..000000000000
--- a/JavaScript.Platform.h.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h 2017-12-03 15:17:32.109008745 -0300
-+++ b/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h 2017-12-03 15:18:07.382415362 -0300
-@@ -377,7 +377,7 @@
-
- #if (defined(mips) || defined(__mips__) || defined(MIPS) || defined(_MIPS_))
- #define WTF_CPU_MIPS 1
--#include <sgidefs.h>
-+#include <asm/sgidefs.h>
- #if defined(__MIPSEB__)
- #define WTF_CPU_BIG_ENDIAN 1
- #endif
diff --git a/JavaScriptCore.pri.patch b/JavaScriptCore.pri.patch
deleted file mode 100644
index c3e389bad7ef..000000000000
--- a/JavaScriptCore.pri.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/JavaScriptCore.pri 2015-10-13 01:35:45.000000000 -0300
-+++ b/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/JavaScriptCore.pri 2016-02-29 08:14:22.211014081 -0300
-@@ -45,6 +45,7 @@
- msvc: DEFINES += _CRT_RAND_S
- LIBS_PRIVATE += -lwinmm
- }
-+JAVASCRIPTCORE_JIT = no
- contains(JAVASCRIPTCORE_JIT,yes) {
- DEFINES+=ENABLE_JIT=1
- DEFINES+=ENABLE_YARR_JIT=1
diff --git a/PKGBUILD b/PKGBUILD
index 49748582868a..8a956b61585d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,24 @@
-#PKGCONFIG for android-qt5
+# PKGCONFIG for android-qt5
# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
# Contributor: Jiaxi Hu <sftrytry _AT_ gmail _DOT_ com>
# Contributor: jimmy00784 <jimmy00784@gmail.com>
# Contributor: Ricardo (XenGi) Band <email@ricardo.band>
+# Useful link to keep track of latest API changes:
+#
+# https://developer.android.com/ndk/downloads/revision_history
+
android_arch=x86
-if [ -z "${ANDROID_MINIMUM_PLATFORM}" ]; then
- case "$android_arch" in
- arm64-v8a)
- export ANDROID_MINIMUM_PLATFORM=21
- ;;
- x86_64)
- export ANDROID_MINIMUM_PLATFORM=21
- ;;
- *)
- export ANDROID_MINIMUM_PLATFORM=16
- ;;
- esac
-fi
+# Minimum Android platform based on:
+#
+# https://developer.android.com/about/dashboards/
+ANDROID_MINIMUM_PLATFORM=21
+export ANDROID_MINIMUM_PLATFORM
_pkgname=android-qt5
pkgname=${_pkgname}-${android_arch}
-pkgver=5.10.1
+pkgver=5.11.0
pkgrel=1
pkgdesc="Qt 5 for Android"
arch=('x86_64')
@@ -67,31 +63,13 @@ options=('!strip'
'staticlibs'
'!emptydirs')
_pkgfqn="qt-everywhere-src-${pkgver}"
-source=("http://download.qt-project.org/official_releases/qt/${pkgver:0:4}/${pkgver}/single/${_pkgfqn}.tar.xz"
- "geoservices.pro.patch"
- "JavaScriptCore.pri.patch"
- "JavaScript.Platform.h.patch")
-md5sums=('7e167b9617e7bd64012daaacb85477af'
- 'de535e2ce98e9f75e9ec0ed1c52a2647'
- 'd0b3bb4de8a44520c2923e14a8b4f9f1'
- '4c9bbe21230e34fa07c2cbd5119ceda9')
+source=("http://download.qt-project.org/official_releases/qt/${pkgver:0:4}/${pkgver}/single/${_pkgfqn}.tar.xz")
+md5sums=('68b7c9dd5c5df84b5c82730474c4c1f3')
prepare() {
cd ${_pkgfqn}
# Platform specific patches.
- case "$android_arch" in
- mips)
- patch -Np1 -i "../JavaScript.Platform.h.patch"
- ;;
- armeabi)
- # Disable JIT.
- patch -Np1 -i "../JavaScriptCore.pri.patch"
- patch -Np1 -i "../geoservices.pro.patch"
- ;;
- *)
- ;;
- esac
}
get_last() {
@@ -109,13 +87,6 @@ build() {
unset CHOST
unset QMAKESPEC
unset QTDIR
-
- if [ "${CARCH}" == 'i686' ]; then
- ndkhost='linux-x86'
- elif [ "${CARCH}" == 'x86_64' ]; then
- ndkhost='linux-x86_64'
- fi
-
unset CARCH
export ANDROID_NDK_ROOT=/opt/android-ndk
@@ -148,7 +119,7 @@ build() {
-nomake examples
-android-ndk ${ANDROID_NDK_ROOT}
-android-sdk ${ANDROID_SDK_ROOT}
- -android-ndk-host ${ndkhost}
+ -android-ndk-host linux-x86_64
-android-toolchain-version 4.9
-skip qttranslations
-skip qtserialport
@@ -159,17 +130,8 @@ build() {
-android-arch ${android_arch}
-android-ndk-platform ${ANDROID_NDK_PLATFORM}"
- if [ "$ANDROID_MINIMUM_PLATFORM" -lt 18 ]; then
- configue_opts+="
- -skip qtconnectivity"
- fi
-
# Platform specific patches
case "$android_arch" in
- armeabi)
- configue_opts+="
- -skip qtwebglplugin"
- ;;
x86*)
configue_opts+="
-no-sql-mysql
@@ -194,14 +156,10 @@ package() {
toolchain=aarch64-linux-android-4.9
stripFolder=aarch64-linux-android
;;
- armeabi*)
+ armeabi-v7a)
toolchain=arm-linux-androideabi-4.9
stripFolder=arm-linux-androideabi
;;
- mips)
- toolchain=mipsel-linux-android-4.9
- stripFolder=mipsel-linux-android
- ;;
x86)
toolchain=x86-4.9
stripFolder=i686-linux-android
diff --git a/geoservices.pro.patch b/geoservices.pro.patch
deleted file mode 100644
index d2e8366ba561..000000000000
--- a/geoservices.pro.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/qtlocation/src/plugins/geoservices/geoservices.pro 2017-05-19 14:42:14.000000000 -0300
-+++ b/qtlocation/src/plugins/geoservices/geoservices.pro 2017-06-10 13:46:34.743784296 -0300
-@@ -10,7 +10,7 @@
- !exists(../../3rdparty/mapbox-gl-native/CMakeLists.txt) {
- warning("Submodule mapbox-gl-native does not exist. Run 'git submodule update --init' on qtlocation.")
- } else {
-- SUBDIRS += mapboxgl ../../3rdparty/mapbox-gl-native
-- mapboxgl.depends = ../../3rdparty/mapbox-gl-native
-+# SUBDIRS += mapboxgl ../../3rdparty/mapbox-gl-native
-+# mapboxgl.depends = ../../3rdparty/mapbox-gl-native
- }
- }