summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2018-09-24 10:36:22 -0300
committerGonzalo Exequiel Pedone2018-09-24 10:36:22 -0300
commit1e63a96d0db10339557d482e6e17be7f7790dc74 (patch)
tree7be1df2926144df4ad213d2fa5fee5b93c6f3894
parent3ca8f5be5e50fed0583343c87b53c0cf428e71a3 (diff)
downloadaur-1e63a96d0db10339557d482e6e17be7f7790dc74.tar.gz
Updated to Qt 5.11.2.
-rw-r--r--.SRCINFO14
-rw-r--r--0001-Fix-clang-build.patch23
-rw-r--r--0034-Fix-build-error-related-to-glibc-2.28-and-stat.patch69
-rw-r--r--PKGBUILD29
4 files changed, 46 insertions, 89 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d84bd4e9086..8c25466451d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# jue sep 6 14:32:34 UTC 2018
+# lun sep 24 13:31:07 UTC 2018
pkgbase = android-qt5-x86
pkgdesc = Qt 5 for Android
- pkgver = 5.11.1
- pkgrel = 2
+ pkgver = 5.11.2
+ pkgrel = 1
url = https://www.qt.io
arch = x86_64
groups = android-qt5
@@ -30,10 +30,10 @@ pkgbase = android-qt5-x86
options = !buildflags
options = staticlibs
options = !emptydirs
- source = http://download.qt-project.org/official_releases/qt/5.11/5.11.1/single/qt-everywhere-src-5.11.1.tar.xz
- source = 0034-Fix-build-error-related-to-glibc-2.28-and-stat.patch
- md5sums = c6f0854d7de7bde80cfd8cc85bb7152b
- md5sums = SKIP
+ source = http://download.qt-project.org/official_releases/qt/5.11/5.11.2/single/qt-everywhere-src-5.11.2.tar.xz
+ source = 0001-Fix-clang-build.patch
+ md5sums = 152a8ade9c11fe33ff5bc95310a1bb64
+ md5sums = 511eafcabe9e0c6210f1dc5e26daa5c8
pkgname = android-qt5-x86
diff --git a/0001-Fix-clang-build.patch b/0001-Fix-clang-build.patch
new file mode 100644
index 000000000000..431f20e727e1
--- /dev/null
+++ b/0001-Fix-clang-build.patch
@@ -0,0 +1,23 @@
+--- a/qtbase/mkspecs/android-clang/qmake.conf 2018-09-13 01:25:10.000000000 -0300
++++ b/qtbase/mkspecs/android-clang/qmake.conf 2018-09-23 15:53:19.000000000 -0300
+@@ -31,16 +31,17 @@
+
+ QMAKE_CFLAGS += -gcc-toolchain $$NDK_TOOLCHAIN_PATH
+ QMAKE_LINK = $$QMAKE_CXX $$QMAKE_CFLAGS -Wl,--exclude-libs,libgcc.a
+-QMAKE_CFLAGS += -DANDROID_HAS_WSTRING --sysroot=$$NDK_ROOT/sysroot \
++QMAKE_CFLAGS += -DANDROID_HAS_WSTRING --sysroot=$$ANDROID_PLATFORM_ROOT_PATH \
+ -isystem $$NDK_ROOT/sysroot/usr/include/$$NDK_TOOLS_PREFIX \
+ -isystem $$NDK_ROOT/sources/cxx-stl/llvm-libc++/include \
+ -isystem $$NDK_ROOT/sources/android/support/include \
+- -isystem $$NDK_ROOT/sources/cxx-stl/llvm-libc++abi/include
++ -isystem $$NDK_ROOT/sources/cxx-stl/llvm-libc++abi/include \
++ -isystem $$NDK_ROOT/sysroot/usr/include
+
+ ANDROID_SOURCES_CXX_STL_LIBDIR = $$NDK_ROOT/sources/cxx-stl/llvm-libc++/libs/$$ANDROID_TARGET_ARCH
+
+ ANDROID_STDCPP_PATH = $$ANDROID_SOURCES_CXX_STL_LIBDIR/libc++_shared.so
+-ANDROID_CXX_STL_LIBS = -lc++
++ANDROID_CXX_STL_LIBS = -lc++_shared
+
+ QMAKE_CFLAGS_OPTIMIZE_SIZE = -Oz
+
diff --git a/0034-Fix-build-error-related-to-glibc-2.28-and-stat.patch b/0034-Fix-build-error-related-to-glibc-2.28-and-stat.patch
deleted file mode 100644
index 02c1e798e114..000000000000
--- a/0034-Fix-build-error-related-to-glibc-2.28-and-stat.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-From 0fc1e355f07235ca7fe1f04d7206394772c6b5f4 Mon Sep 17 00:00:00 2001
-From: Martchus <martchus@gmx.net>
-Date: Sat, 25 Aug 2018 11:44:46 +0200
-Subject: [PATCH 34/34] Fix build error related to glibc 2.28 and stat
-
-Taken from regular package, comes from Fedora
----
- mkspecs/linux-g++/qplatformdefs.h | 2 ++
- src/corelib/io/qfilesystemengine_unix.cpp | 10 +++++++---
- 2 files changed, 9 insertions(+), 3 deletions(-)
-
-diff --git a/qtbase/mkspecs/linux-g++/qplatformdefs.h b/qtbase/mkspecs/linux-g++/qplatformdefs.h
-index 13523f0702..d32453162c 100644
---- a/qtbase/mkspecs/linux-g++/qplatformdefs.h
-+++ b/qtbase/mkspecs/linux-g++/qplatformdefs.h
-@@ -72,7 +72,9 @@
- #include <sys/time.h>
- #include <sys/shm.h>
- #include <sys/socket.h>
-+#if 0
- #include <sys/stat.h>
-+#endif
- #include <sys/wait.h>
- #include <netinet/in.h>
-
-diff --git a/qtbase/src/corelib/io/qfilesystemengine_unix.cpp b/qtbase/src/corelib/io/qfilesystemengine_unix.cpp
-index be6ce48d0c..3648cfc43d 100644
---- a/qtbase/src/corelib/io/qfilesystemengine_unix.cpp
-+++ b/qtbase/src/corelib/io/qfilesystemengine_unix.cpp
-@@ -50,7 +50,9 @@
- #include <pwd.h>
- #include <stdlib.h> // for realpath()
- #include <sys/types.h>
-+#if 0
- #include <sys/stat.h>
-+#endif
- #include <unistd.h>
- #include <stdio.h>
- #include <errno.h>
-@@ -91,7 +93,9 @@ extern "C" NSString *NSTemporaryDirectory();
- # include <sys/syscall.h>
- # include <sys/sendfile.h>
- # include <linux/fs.h>
-+#if 0
- # include <linux/stat.h>
-+#endif
-
- // in case linux/fs.h is too old and doesn't define it:
- #ifndef FICLONE
-@@ -105,13 +109,13 @@ extern "C" NSString *NSTemporaryDirectory();
- # undef SYS_renameat2
- # undef SYS_statx
- # undef STATX_BASIC_STATS
--# else
--# if !QT_CONFIG(renameat2) && defined(SYS_renameat2)
-+# else
-+# if 0 && !QT_CONFIG(renameat2) && defined(SYS_renameat2)
- static int renameat2(int oldfd, const char *oldpath, int newfd, const char *newpath, unsigned flags)
- { return syscall(SYS_renameat2, oldfd, oldpath, newfd, newpath, flags); }
- # endif
-
--# if !QT_CONFIG(statx) && defined(SYS_statx)
-+# if 0 && !QT_CONFIG(statx) && defined(SYS_statx)
- static int statx(int dirfd, const char *pathname, int flag, unsigned mask, struct statx *statxbuf)
- { return syscall(SYS_statx, dirfd, pathname, flag, mask, statxbuf); }
- # elif !QT_CONFIG(statx) && !defined(SYS_statx)
---
-2.18.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 08a5d6b80bf4..88f985eaff70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,8 +18,8 @@ export ANDROID_MINIMUM_PLATFORM
_pkgname=android-qt5
pkgname=${_pkgname}-${android_arch}
-pkgver=5.11.1
-pkgrel=2
+pkgver=5.11.2
+pkgrel=1
pkgdesc="Qt 5 for Android"
arch=('x86_64')
url='https://www.qt.io'
@@ -64,17 +64,15 @@ options=('!strip'
'!emptydirs')
_pkgfqn="qt-everywhere-src-${pkgver}"
source=("http://download.qt-project.org/official_releases/qt/${pkgver:0:4}/${pkgver}/single/${_pkgfqn}.tar.xz"
- "0034-Fix-build-error-related-to-glibc-2.28-and-stat.patch")
-md5sums=('c6f0854d7de7bde80cfd8cc85bb7152b'
- 'SKIP')
+ "0001-Fix-clang-build.patch")
+md5sums=('152a8ade9c11fe33ff5bc95310a1bb64'
+ '511eafcabe9e0c6210f1dc5e26daa5c8')
prepare() {
cd ${_pkgfqn}
# Platform specific patches.
-
- # Apply patch for glibc 2.28
- patch -Np1 -i "../0034-Fix-build-error-related-to-glibc-2.28-and-stat.patch"
+ patch -Np1 -i "../0001-Fix-clang-build.patch"
}
get_last() {
@@ -111,7 +109,7 @@ build() {
export ANDROID_NDK_PLATFORM=android-$ANDROID_MINIMUM_PLATFORM
fi
- _pref=/opt/${_pkgname}/${pkgver}/${android_arch}
+ _pref=/opt/${_pkgname}/${android_arch}
configue_opts="
-confirm-license
@@ -119,7 +117,7 @@ build() {
-silent
-prefix ${_pref}
-docdir ${_pref}/doc
- -xplatform android-g++
+ -xplatform android-clang
-nomake tests
-nomake examples
-android-ndk ${ANDROID_NDK_ROOT}
@@ -135,6 +133,11 @@ build() {
-android-arch ${android_arch}
-android-ndk-platform ${ANDROID_NDK_PLATFORM}"
+ # qtlocation needs mapbox-gl-native, and mapbox-gl-native needs C++17 and
+ # higher so disable it for a while.
+ configue_opts+="
+ -skip qtlocation"
+
# Platform specific patches
case "$android_arch" in
x86*)
@@ -177,7 +180,7 @@ package() {
export ANDROID_NDK_ROOT=/opt/android-ndk
STRIP=${ANDROID_NDK_ROOT}/toolchains/${toolchain}/prebuilt/linux-x86_64/${stripFolder}/bin/strip
- find ${pkgdir}/opt/${_pkgname}/${pkgver}/${android_arch}/lib -name 'lib*.so' -exec ${STRIP} {} \;
- find ${pkgdir}/opt/${_pkgname}/${pkgver}/${android_arch}/lib \( -name 'lib*.a' ! -name 'libQt5Bootstrap.a' ! -name 'libQt5QmlDevTools.a' \) -exec ${STRIP} {} \;
- find ${pkgdir}/opt/${_pkgname}/${pkgver}/${android_arch}/plugins -name 'lib*.so' -exec ${STRIP} {} \;
+ find ${pkgdir}/opt/${_pkgname}/${android_arch}/lib -name 'lib*.so' -exec ${STRIP} {} \;
+ find ${pkgdir}/opt/${_pkgname}/${android_arch}/lib \( -name 'lib*.a' ! -name 'libQt5Bootstrap.a' ! -name 'libQt5QmlDevTools.a' \) -exec ${STRIP} {} \;
+ find ${pkgdir}/opt/${_pkgname}/${android_arch}/plugins -name 'lib*.so' -exec ${STRIP} {} \;
}