summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2016-02-29 11:54:21 -0300
committerGonzalo Exequiel Pedone2016-02-29 11:54:21 -0300
commit1ea080c59a97e85308656dfcd869422cceaf9be3 (patch)
treece9ae547ade892ac7290aa30d239608868b74667
downloadaur-1ea080c59a97e85308656dfcd869422cceaf9be3.tar.gz
First commit.
-rw-r--r--.SRCINFO41
-rw-r--r--.gitignore4
-rw-r--r--JavaScriptCore.pri.patch10
-rw-r--r--Misc.cpp.patch21
-rw-r--r--PKGBUILD124
-rw-r--r--qglobal.h.patch11
6 files changed, 211 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c3deff4176d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+# Generated by mksrcinfo v8
+# lun feb 29 14:54:05 UTC 2016
+pkgbase = android-qt5-x86
+ pkgdesc = Qt 5 for Android
+ pkgver = 5.5.1
+ pkgrel = 1
+ url = https://www.qt.io
+ arch = i686
+ arch = x86_64
+ groups = qt-android
+ license = GPL3
+ license = LGPL
+ makedepends = libgl
+ makedepends = sqlite
+ makedepends = zlib
+ makedepends = python2
+ makedepends = ruby
+ makedepends = gperf
+ makedepends = libxslt
+ makedepends = fontconfig
+ depends = java-runtime-headless>=7
+ depends = apache-ant
+ depends = android-ndk
+ depends = android-platform
+ depends = android-sdk
+ depends = android-sdk-build-tools
+ depends = android-sdk-platform-tools
+ optdepends = android-google-apis-x86: AVD support
+ optdepends = android-x86-system-image: AVD support
+ conflicts = qt-android
+ source = http://download.qt-project.org/official_releases/qt/5.5/5.5.1/single/qt-everywhere-opensource-src-5.5.1.tar.xz
+ source = qglobal.h.patch
+ source = Misc.cpp.patch
+ source = JavaScriptCore.pri.patch
+ sha256sums = 6f028e63d4992be2b4a5526f2ef3bfa2fe28c5c757554b11d9e8d86189652518
+ sha256sums = fc735eda1209661f78067ea5649c9ceceeb7e49804d5de5975c4e5fbfbf34d7e
+ sha256sums = 096eef8234f0ea964ac20ca887c8da2e7b5b836de417515acde103c2a27a04de
+ sha256sums = 133dad6c8d0bedaa5d561be26b2f7185e671900c50d11476ecb2e2ef6792d455
+
+pkgname = android-qt5-x86
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5bc2aa573e1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.tar.xz
+*.tar.gz
diff --git a/JavaScriptCore.pri.patch b/JavaScriptCore.pri.patch
new file mode 100644
index 000000000000..c3e389bad7ef
--- /dev/null
+++ b/JavaScriptCore.pri.patch
@@ -0,0 +1,10 @@
+--- a/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/JavaScriptCore.pri 2015-10-13 01:35:45.000000000 -0300
++++ b/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/JavaScriptCore.pri 2016-02-29 08:14:22.211014081 -0300
+@@ -45,6 +45,7 @@
+ msvc: DEFINES += _CRT_RAND_S
+ LIBS_PRIVATE += -lwinmm
+ }
++JAVASCRIPTCORE_JIT = no
+ contains(JAVASCRIPTCORE_JIT,yes) {
+ DEFINES+=ENABLE_JIT=1
+ DEFINES+=ENABLE_YARR_JIT=1
diff --git a/Misc.cpp.patch b/Misc.cpp.patch
new file mode 100644
index 000000000000..1249c824ef55
--- /dev/null
+++ b/Misc.cpp.patch
@@ -0,0 +1,21 @@
+--- a/qttools/src/assistant/3rdparty/clucene/src/CLucene/util/Misc.cpp 2015-10-13 01:38:13.000000000 -0300
++++ b/qttools/src/assistant/3rdparty/clucene/src/CLucene/util/Misc.cpp 2016-02-28 12:04:12.637069234 -0300
+@@ -10,6 +10,18 @@
+ #include "Misc.h"
+
+ #ifdef _CL_TIME_WITH_SYS_TIME
++#undef _CL_TIME_WITH_SYS_TIME
++#endif
++
++#ifdef _CL_HAVE_SYS_TIME_H
++#undef _CL_HAVE_SYS_TIME_H
++#endif
++
++#ifdef _CL_HAVE_SYS_TIMEB_H
++#undef _CL_HAVE_SYS_TIMEB_H
++#endif
++
++#ifdef _CL_TIME_WITH_SYS_TIME
+ # include <sys/time.h>
+ # include <time.h>
+ #else
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3989386546ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,124 @@
+#PKGCONFIG for android-qt5 for qt 5.5
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+# Contributor: Jiaxi Hu <sftrytry _AT_ gmail _DOT_ com>
+# Contributor: jimmy00784 <jimmy00784@gmail.com>
+# Contributor: Ricardo (XenGi) Band <email@ricardo.band>
+
+android_arch=x86
+_pkgname=android-qt5
+pkgname=${_pkgname}-${android_arch}
+pkgver=5.5.1
+_pkgver=5.5
+pkgrel=1
+pkgdesc="Qt 5 for Android"
+arch=('i686' 'x86_64')
+url='https://www.qt.io'
+license=('GPL3' 'LGPL')
+makedepends=('libgl'
+ 'sqlite'
+ 'zlib'
+ 'python2'
+ 'ruby'
+ 'gperf'
+ 'libxslt'
+ 'fontconfig')
+depends=('java-runtime-headless>=7'
+ 'apache-ant'
+ 'android-ndk'
+ 'android-platform'
+ 'android-sdk'
+ 'android-sdk-build-tools'
+ 'android-sdk-platform-tools')
+groups=('qt-android')
+# Uninstalling 'tk' and 'tcl' packages is recommended since it causes build
+# conflicts.
+conflicts=('qt-android')
+
+case "$android_arch" in
+ arm*)
+ optdepends=('android-google-apis-armv7a-eabi: AVD support'
+ 'android-armv7a-eabi-system-image: AVD support')
+ ;;
+ x86)
+ optdepends=('android-google-apis-x86: AVD support'
+ 'android-x86-system-image: AVD support')
+ ;;
+ x86_64)
+ optdepends=('android-google-apis-x86-64: AVD support'
+ 'android-x86-64-system-image: AVD support')
+ ;;
+ *)
+ ;;
+esac
+
+_pkgfqn="qt-everywhere-opensource-src-${pkgver}"
+source=("http://download.qt-project.org/official_releases/qt/${_pkgver}/${pkgver}/single/${_pkgfqn}.tar.xz"
+ "qglobal.h.patch"
+ "Misc.cpp.patch"
+ "JavaScriptCore.pri.patch")
+sha256sums=('6f028e63d4992be2b4a5526f2ef3bfa2fe28c5c757554b11d9e8d86189652518'
+ 'fc735eda1209661f78067ea5649c9ceceeb7e49804d5de5975c4e5fbfbf34d7e'
+ '096eef8234f0ea964ac20ca887c8da2e7b5b836de417515acde103c2a27a04de'
+ '133dad6c8d0bedaa5d561be26b2f7185e671900c50d11476ecb2e2ef6792d455')
+
+prepare() {
+ cd ${_pkgfqn}
+ patch -Np1 -i "../qglobal.h.patch"
+ patch -Np1 -i "../Misc.cpp.patch"
+ patch -Np1 -i "../JavaScriptCore.pri.patch"
+}
+
+build() {
+ cd ${_pkgfqn}
+
+ unset CC
+ unset CXX
+ unset CFLAGS
+ unset CXXFLAGS
+ unset LDFLAGS
+ unset CHOST
+ unset QMAKESPEC
+ unset QTDIR
+
+ if [ "${CARCH}" == 'i686' ]; then
+ ndkhost='linux-x86'
+ elif [ "${CARCH}" == 'x86_64' ]; then
+ ndkhost='linux-x86_64'
+ fi
+
+ unset CARCH
+
+ export ANDROID_SDK_ROOT=/opt/android-sdk
+ export ANDROID_BUILD_TOOLS_REVISION=23.0.2
+ export ANDROID_API_VERSION=android-23
+ export PYTHON=/usr/bin/python2
+
+ _pref=/opt/${_pkgname}/${pkgver}/${android_arch}
+
+ ./configure -confirm-license -opensource \
+ -prefix ${_pref} \
+ -docdir ${_pref}/doc \
+ -xplatform android-g++ \
+ -nomake tests \
+ -nomake examples \
+ -android-ndk /opt/android-ndk \
+ -android-sdk /opt/android-sdk \
+ -android-ndk-host ${ndkhost} \
+ -android-toolchain-version 4.9 \
+ -skip qttranslations \
+ -skip qtwebkit \
+ -skip qtserialport \
+ -skip qtwebkit-examples \
+ -no-warnings-are-errors \
+ -qt-zlib \
+ -qt-freetype \
+ -android-arch ${android_arch} \
+ -android-ndk-platform android-21
+
+ make || return 1
+}
+
+package() {
+ cd ${_pkgfqn}
+ make INSTALL_ROOT=${pkgdir} install
+}
diff --git a/qglobal.h.patch b/qglobal.h.patch
new file mode 100644
index 000000000000..b09c634f5429
--- /dev/null
+++ b/qglobal.h.patch
@@ -0,0 +1,11 @@
+--- a/qtbase/src/corelib/global/qglobal.h 2016-02-27 16:17:48.494720393 -0300
++++ a/qtbase/src/corelib/global/qglobal.h 2016-02-27 16:18:04.938077180 -0300
+@@ -82,7 +82,7 @@
+
+ #ifdef __cplusplus
+
+-#include <algorithm>
++//#include <algorithm>
+
+ #if !defined(QT_NAMESPACE) || defined(Q_MOC_RUN) /* user namespace */
+