summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2018-09-06 11:33:41 -0300
committerGonzalo Exequiel Pedone2018-09-06 11:33:41 -0300
commit3ca8f5be5e50fed0583343c87b53c0cf428e71a3 (patch)
tree00acc606aac7ac225d1a573399dc75d0364a02dd
parent61dd5fc405d53c8ecd74f8769a68a7b313dd9190 (diff)
downloadaur-3ca8f5be5e50fed0583343c87b53c0cf428e71a3.tar.gz
Apply glibc 2.28 patch.
-rw-r--r--.SRCINFO6
-rw-r--r--0034-Fix-build-error-related-to-glibc-2.28-and-stat.patch69
-rw-r--r--PKGBUILD11
3 files changed, 81 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d73d961aa5d9..0d84bd4e9086 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# vie jun 22 22:41:33 UTC 2018
+# jue sep 6 14:32:34 UTC 2018
pkgbase = android-qt5-x86
pkgdesc = Qt 5 for Android
pkgver = 5.11.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.qt.io
arch = x86_64
groups = android-qt5
@@ -31,7 +31,9 @@ pkgbase = android-qt5-x86
options = staticlibs
options = !emptydirs
source = http://download.qt-project.org/official_releases/qt/5.11/5.11.1/single/qt-everywhere-src-5.11.1.tar.xz
+ source = 0034-Fix-build-error-related-to-glibc-2.28-and-stat.patch
md5sums = c6f0854d7de7bde80cfd8cc85bb7152b
+ md5sums = SKIP
pkgname = android-qt5-x86
diff --git a/0034-Fix-build-error-related-to-glibc-2.28-and-stat.patch b/0034-Fix-build-error-related-to-glibc-2.28-and-stat.patch
new file mode 100644
index 000000000000..02c1e798e114
--- /dev/null
+++ b/0034-Fix-build-error-related-to-glibc-2.28-and-stat.patch
@@ -0,0 +1,69 @@
+From 0fc1e355f07235ca7fe1f04d7206394772c6b5f4 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Sat, 25 Aug 2018 11:44:46 +0200
+Subject: [PATCH 34/34] Fix build error related to glibc 2.28 and stat
+
+Taken from regular package, comes from Fedora
+---
+ mkspecs/linux-g++/qplatformdefs.h | 2 ++
+ src/corelib/io/qfilesystemengine_unix.cpp | 10 +++++++---
+ 2 files changed, 9 insertions(+), 3 deletions(-)
+
+diff --git a/qtbase/mkspecs/linux-g++/qplatformdefs.h b/qtbase/mkspecs/linux-g++/qplatformdefs.h
+index 13523f0702..d32453162c 100644
+--- a/qtbase/mkspecs/linux-g++/qplatformdefs.h
++++ b/qtbase/mkspecs/linux-g++/qplatformdefs.h
+@@ -72,7 +72,9 @@
+ #include <sys/time.h>
+ #include <sys/shm.h>
+ #include <sys/socket.h>
++#if 0
+ #include <sys/stat.h>
++#endif
+ #include <sys/wait.h>
+ #include <netinet/in.h>
+
+diff --git a/qtbase/src/corelib/io/qfilesystemengine_unix.cpp b/qtbase/src/corelib/io/qfilesystemengine_unix.cpp
+index be6ce48d0c..3648cfc43d 100644
+--- a/qtbase/src/corelib/io/qfilesystemengine_unix.cpp
++++ b/qtbase/src/corelib/io/qfilesystemengine_unix.cpp
+@@ -50,7 +50,9 @@
+ #include <pwd.h>
+ #include <stdlib.h> // for realpath()
+ #include <sys/types.h>
++#if 0
+ #include <sys/stat.h>
++#endif
+ #include <unistd.h>
+ #include <stdio.h>
+ #include <errno.h>
+@@ -91,7 +93,9 @@ extern "C" NSString *NSTemporaryDirectory();
+ # include <sys/syscall.h>
+ # include <sys/sendfile.h>
+ # include <linux/fs.h>
++#if 0
+ # include <linux/stat.h>
++#endif
+
+ // in case linux/fs.h is too old and doesn't define it:
+ #ifndef FICLONE
+@@ -105,13 +109,13 @@ extern "C" NSString *NSTemporaryDirectory();
+ # undef SYS_renameat2
+ # undef SYS_statx
+ # undef STATX_BASIC_STATS
+-# else
+-# if !QT_CONFIG(renameat2) && defined(SYS_renameat2)
++# else
++# if 0 && !QT_CONFIG(renameat2) && defined(SYS_renameat2)
+ static int renameat2(int oldfd, const char *oldpath, int newfd, const char *newpath, unsigned flags)
+ { return syscall(SYS_renameat2, oldfd, oldpath, newfd, newpath, flags); }
+ # endif
+
+-# if !QT_CONFIG(statx) && defined(SYS_statx)
++# if 0 && !QT_CONFIG(statx) && defined(SYS_statx)
+ static int statx(int dirfd, const char *pathname, int flag, unsigned mask, struct statx *statxbuf)
+ { return syscall(SYS_statx, dirfd, pathname, flag, mask, statxbuf); }
+ # elif !QT_CONFIG(statx) && !defined(SYS_statx)
+--
+2.18.0
+
diff --git a/PKGBUILD b/PKGBUILD
index c79b492290db..08a5d6b80bf4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ export ANDROID_MINIMUM_PLATFORM
_pkgname=android-qt5
pkgname=${_pkgname}-${android_arch}
pkgver=5.11.1
-pkgrel=1
+pkgrel=2
pkgdesc="Qt 5 for Android"
arch=('x86_64')
url='https://www.qt.io'
@@ -63,13 +63,18 @@ options=('!strip'
'staticlibs'
'!emptydirs')
_pkgfqn="qt-everywhere-src-${pkgver}"
-source=("http://download.qt-project.org/official_releases/qt/${pkgver:0:4}/${pkgver}/single/${_pkgfqn}.tar.xz")
-md5sums=('c6f0854d7de7bde80cfd8cc85bb7152b')
+source=("http://download.qt-project.org/official_releases/qt/${pkgver:0:4}/${pkgver}/single/${_pkgfqn}.tar.xz"
+ "0034-Fix-build-error-related-to-glibc-2.28-and-stat.patch")
+md5sums=('c6f0854d7de7bde80cfd8cc85bb7152b'
+ 'SKIP')
prepare() {
cd ${_pkgfqn}
# Platform specific patches.
+
+ # Apply patch for glibc 2.28
+ patch -Np1 -i "../0034-Fix-build-error-related-to-glibc-2.28-and-stat.patch"
}
get_last() {