summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormynacol2020-12-30 14:48:17 +0100
committermynacol2020-12-30 14:48:17 +0100
commit528650baac4ea8314297527f06d59b047ed9e9a0 (patch)
tree5b8858fa004ee9564e1b7374d3432b6408fab781
parenta9f0ac43d7db68bad24e210eaa8b39578e39b8a4 (diff)
downloadaur-528650baac4e.tar.gz
Make symlinks for executables in /usr/bin/
The script in /etc/profile.d/ is now no longer needed. The $PATH is not modified as well.
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 98d00802158a..4130fbbe8375 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,8 +30,11 @@ package() {
cp -r "$srcdir/$_android/"* "$target"
chmod +Xr -R "$target"
- # Add binaries to PATH
- mkdir -p etc/profile.d
- echo "append_path '/$target'" > etc/profile.d/${pkgname}.sh
- chmod 755 etc/profile.d/${pkgname}.sh
+ # Add symlinks to binaries to usr/bin/
+ mkdir -p usr/bin/
+ binaries=("aapt" "aapt2" "aidl" "apksigner" "bcc_compat" "d8" "dexdump" "dx" "lld" "llvm-rs-cc" "mainDexClasses" "split-select" "zipalign")
+ for f in "${binaries[@]}"
+ do
+ ln -s "/$target/$f" "usr/bin/$f"
+ done
}