diff options
author | mynacol | 2020-12-30 14:48:17 +0100 |
---|---|---|
committer | mynacol | 2020-12-30 14:48:17 +0100 |
commit | 528650baac4ea8314297527f06d59b047ed9e9a0 (patch) | |
tree | 5b8858fa004ee9564e1b7374d3432b6408fab781 | |
parent | a9f0ac43d7db68bad24e210eaa8b39578e39b8a4 (diff) | |
download | aur-528650baac4ea8314297527f06d59b047ed9e9a0.tar.gz |
Make symlinks for executables in /usr/bin/
The script in /etc/profile.d/ is now no longer needed.
The $PATH is not modified as well.
-rw-r--r-- | PKGBUILD | 11 |
1 files changed, 7 insertions, 4 deletions
@@ -30,8 +30,11 @@ package() { cp -r "$srcdir/$_android/"* "$target" chmod +Xr -R "$target" - # Add binaries to PATH - mkdir -p etc/profile.d - echo "append_path '/$target'" > etc/profile.d/${pkgname}.sh - chmod 755 etc/profile.d/${pkgname}.sh + # Add symlinks to binaries to usr/bin/ + mkdir -p usr/bin/ + binaries=("aapt" "aapt2" "aidl" "apksigner" "bcc_compat" "d8" "dexdump" "dx" "lld" "llvm-rs-cc" "mainDexClasses" "split-select" "zipalign") + for f in "${binaries[@]}" + do + ln -s "/$target/$f" "usr/bin/$f" + done } |