summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormynacol2022-06-12 01:34:25 +0200
committermynacol2022-06-12 01:34:25 +0200
commit70c6f13e497730d3f7d905af7b549ffe367a41ec (patch)
tree4ec0ae49a527cde70be797450bc5d2d179d8127a
parent7a16f4edcf490948018b34fabb1065aa9be046e6 (diff)
downloadaur-70c6f13e497730d3f7d905af7b549ffe367a41ec.tar.gz
Avoid grep
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f6ba89ff6c20..8a6f870b38d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -39,7 +39,7 @@ package() {
# Add symlinks to binaries to usr/bin/
mkdir -p usr/bin/
# lld is also provided by extra/lld, not creating symlink
- binaries=$(find "${target}" -maxdepth 1 -type f -executable -printf "%f\n" | grep -v lld)
+ binaries=$(find "${target}" -maxdepth 1 -type f -executable -not -iname lld -printf "%f\n")
for f in ${binaries[@]}
do
ln -s "/$target/$f" "usr/bin/$f"