summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarren Ng2020-04-08 20:41:56 +0800
committerDarren Ng2020-04-08 20:41:56 +0800
commitb25b2258913f8b1039bba4dc12954d3b27501d3e (patch)
tree0a1bc98deace5934268544182392e39fd50c284c
downloadaur-b25b2258913f8b1039bba4dc12954d3b27501d3e.tar.gz
init
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD25
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2d45e732505
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = android-simg2img
+ pkgdesc = Tool to convert Android sparse images to raw images (standalone, avoid complex building chains)
+ pkgver = 1.1.4
+ pkgrel = 1
+ url = https://github.com/anestisb/android-simg2img
+ arch = x86_64
+ license = Apache
+ depends = zlib
+ conflicts = simg-tools
+ source = android-simg2img-1.1.4.tar.gz::https://github.com/anestisb/android-simg2img/archive/1.1.4.tar.gz
+ sha256sums = cbd32490c1e29d9025601b81089b5aec1707cb62020dfcecd8747af4fde6fecd
+
+pkgname = android-simg2img
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c6a9b954b0ed
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..926ed814406a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Darren Ng <$(base64 --decode <<<'ZGFycmVuMTk5NzA4MTBAZ21haWwuY29tCg==')>
+
+pkgname=android-simg2img
+pkgver=1.1.4
+pkgrel=1
+pkgdesc="Tool to convert Android sparse images to raw images (standalone, avoid complex building chains)"
+arch=("x86_64")
+url="https://github.com/anestisb/android-simg2img"
+license=("Apache")
+depends=("zlib")
+conflicts=("simg-tools")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/anestisb/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('cbd32490c1e29d9025601b81089b5aec1707cb62020dfcecd8747af4fde6fecd')
+
+# build() {
+# cd "$pkgname-$pkgver"
+# make PREFIX="$pkgdir/usr" all
+# }
+
+package() {
+ cd "$pkgname-$pkgver"
+ make PREFIX="$pkgdir/usr" install
+}
+
+