summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJérémy "Vrakfall" Lecocq2018-11-02 05:30:09 +0100
committerJérémy "Vrakfall" Lecocq2018-11-02 05:30:09 +0100
commit8072071f70823452837a91fb5810154fdcdff469 (patch)
tree39057bbb68a99ccfe8ebd41c1cc4bc11c25f7f5f
downloadaur-8072071f70823452837a91fb5810154fdcdff469.tar.gz
Android sources v27-r01. Imported from previous versions' packages.
Signed-off-by: Jérémy "Vrakfall" Lecocq <jeremy@artphotolaurent.be>
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD28
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c752bc828e32
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+#@IgnoreInspection BashAddShebang
+pkgbase = android-sources-27
+ pkgdesc = Android SDK Sources, API-27
+ pkgver = 8.1.0_r01
+ pkgrel = 1
+ url = https://developer.android.com/studio/index.html
+ arch = any
+ license = custom
+ conflicts = android-sources=27
+ options = !strip
+ source = https://dl.google.com/android/repository/sources-27_r01.zip
+ sha1sums = 2af701ee3223d580409288540b1d06932fd8f9b9
+
+pkgname = android-sources-27
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c51efac612b0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+# IntelliJ project files
+.idea
+*.iml
+out
+gen
+
+# Generated files
+sources-*.zip
+android-sources-*.pkg.tar.xz
+src
+pkg \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f7445658018
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+#@IgnoreInspection BashAddShebang
+# Maintainer: Jérémy "Vrakfall" Lecocq <jeremy at artphotolaurent dot be>
+# Contributor: Bence Hornák <hornak dot bence at gmail dot com>
+# Contributor: Philipp Wolfer <ph.wolfer@gmail.com>
+# Contributor: Joel Pedraza <joel@joelpedraza.com>
+# Contributor: Jakub Schmidtke <sjakub-at-gmail-dot-com>
+
+_rev=r01
+_sdkint=27
+_sdkver=8.1.0
+pkgname="android-sources-${_sdkint}"
+pkgver="${_sdkver}_${_rev}"
+pkgrel=1
+pkgdesc="Android SDK Sources, API-${_sdkint}"
+arch=(any)
+url="https://developer.android.com/studio/index.html"
+license=('custom')
+conflicts=("android-sources=${_sdkint}")
+options=('!strip')
+source=("https://dl.google.com/android/repository/sources-${_sdkint}_${_rev}.zip")
+sha256sums=('8e3c1f85fc147b567f342552d6ead2e526df6ba6aa283264e4ebbf1f823be5cc')
+
+
+package() {
+ mkdir -p "${pkgdir}/opt/android-sdk/sources/"
+ cp -dpr --no-preserve=ownership "${srcdir}/src" "${pkgdir}/opt/android-sdk/sources/android-${_sdkint}"
+ chmod -R ugo+rX "${pkgdir}/opt"
+} \ No newline at end of file