summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJérémy "Vrakfall" Lecocq2019-10-29 17:02:13 +0100
committerJérémy "Vrakfall" Lecocq2019-10-29 17:02:13 +0100
commit38a81c03a26b42fbaa928ff34102bc914e876581 (patch)
tree2f724323c23a9969afed0e93bc02824c0f0b74bd
downloadaur-38a81c03a26b42fbaa928ff34102bc914e876581.tar.gz
Updated to version `29_10.0.0_r01`
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD30
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60579232cded
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = android-sources-29
+ pkgdesc = Android SDK Sources, API-29
+ pkgver = 29_10.0.0_r01
+ pkgrel = 1
+ url = https://developer.android.com/studio/index.html
+ arch = any
+ license = custom
+ provides = android-sources
+ options = !strip
+ source = https://dl.google.com/android/repository/sources-29_r01.zip
+ sha256sums = aed4feed3a30ad6b43aa79be6885218985c5425d26e74bd41f3a4c329de2459a
+
+pkgname = android-sources-29
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c51efac612b0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+# IntelliJ project files
+.idea
+*.iml
+out
+gen
+
+# Generated files
+sources-*.zip
+android-sources-*.pkg.tar.xz
+src
+pkg \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80662e8f8ca8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+#@IgnoreInspection BashAddShebang
+# Maintainer: Jérémy "Vrakfall" Lecocq <jeremy at artphotolaurent dot be>
+# Contributor: Bence Hornák <hornak dot bence at gmail dot com>
+# Contributor: lestb <tkhdlstfl dot l plus aur at gmail dot com>
+# Contributor: danyf90 <daniele.formichelli@gmail.com>
+# Contributor: Philipp Wolfer <ph.wolfer@gmail.com>
+# Contributor: Joel Pedraza <joel@joelpedraza.com>
+# Contributor: Jakub Schmidtke <sjakub-at-gmail-dot-com>
+
+_rev=r01
+_sdkint=29
+_sdkver=10.0.0
+pkgname="android-sources-${_sdkint}"
+pkgver="${_sdkint}_${_sdkver}_${_rev}"
+pkgrel=1
+pkgdesc="Android SDK Sources, API-${_sdkint}"
+arch=('any')
+url="https://developer.android.com/studio/index.html"
+license=('custom')
+provides=("android-sources")
+options=('!strip')
+source=("https://dl.google.com/android/repository/sources-${_sdkint}_${_rev}.zip")
+sha256sums=('aed4feed3a30ad6b43aa79be6885218985c5425d26e74bd41f3a4c329de2459a')
+
+
+package() {
+ mkdir -p "${pkgdir}/opt/android-sdk/sources/"
+ cp -dpr --no-preserve=ownership "${srcdir}/src" "${pkgdir}/opt/android-sdk/sources/android-${_sdkint}"
+ chmod -R ugo+rX "${pkgdir}/opt"
+}