summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoronurmercury2023-09-14 13:35:50 +0300
committeronurmercury2023-09-14 13:36:05 +0300
commit84e7c0c4a36c6e1081983db85cc89eb1d657bed0 (patch)
tree6370ddf782d79647387a0721619ef549bb85f37e
parent2b700ce7f8511503c20e2c77b274a7941a382216 (diff)
downloadaur-84e7c0c4a36c6e1081983db85cc89eb1d657bed0.tar.gz
Use bsdtar to extract AndroidStudioApplicationInfo.xml
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fcd2a57bfe5d..2a1f14f559f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ pkgdesc='The Official Android IDE (Beta branch)'
arch=('i686' 'x86_64')
url='https://developer.android.com/studio/preview'
license=('APACHE')
-makedepends=('unzip' 'zip')
+makedepends=('zip')
depends=(
'fontconfig'
'freetype2'
@@ -68,7 +68,7 @@ build() {
# Change the product name to produce a unique WM_CLASS attribute
mkdir -p idea
- unzip -p lib/resources.jar idea/AndroidStudioApplicationInfo.xml \
+ bsdtar -Oxf lib/resources.jar idea/AndroidStudioApplicationInfo.xml \
| sed "s/\"Studio\"/\"Studio Beta\"/" > idea/AndroidStudioApplicationInfo.xml
zip -r lib/resources.jar idea
rm -r idea