summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2019-04-24 11:17:50 -0300
committerGonzalo Exequiel Pedone2019-04-24 11:17:50 -0300
commitc2902870e92236af828556847c95a46de7cd2a6c (patch)
tree78df0376ebdb662806efc54e3c9d0683343131db
parent70225f20dc53af179f61cd7b07710c735a4ee79f (diff)
downloadaur-c2902870e92236af828556847c95a46de7cd2a6c.tar.gz
Package updated.
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD18
-rwxr-xr-xandroid-env.sh2
4 files changed, 20 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f72c6b30725f..800d99b2294f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
# Generated by mksrcinfo v8
-# lun abr 15 19:51:31 UTC 2019
+# miƩ abr 24 14:13:49 UTC 2019
pkgbase = android-x86-64-ffmpeg
pkgdesc = Complete solution to record, convert and stream audio and video (android)
pkgver = 4.1.3
- pkgrel = 1
+ pkgrel = 2
url = http://ffmpeg.org/
arch = any
license = GPL3
makedepends = android-pkg-config
makedepends = yasm
+ depends = android-x86-64-bzip2
+ depends = android-x86-64-libtheora
depends = android-x86-64-libvorbis
depends = android-x86-64-libvpx
depends = android-x86-64-opus
+ depends = android-x86-64-zlib
options = !strip
options = !buildflags
options = staticlibs
diff --git a/.gitignore b/.gitignore
index 78bc5ca47508..47731b2e7117 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,4 @@ pkg
src
*.tar.xz
*.tar.gz
-ffmpeg
+*.tar.bz2
diff --git a/PKGBUILD b/PKGBUILD
index 70d1d403e84e..4a93c70e8746 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,17 @@ source android-env.sh ${_android_arch}
pkgname=android-${_android_arch}-ffmpeg
pkgver=4.1.3
-pkgrel=1
+pkgrel=2
pkgdesc="Complete solution to record, convert and stream audio and video (android)"
arch=('any')
url="http://ffmpeg.org/"
license=('GPL3')
-depends=("android-${_android_arch}-libvorbis"
+depends=("android-${_android_arch}-bzip2"
+ "android-${_android_arch}-libtheora"
+ "android-${_android_arch}-libvorbis"
"android-${_android_arch}-libvpx"
- "android-${_android_arch}-opus")
+ "android-${_android_arch}-opus"
+ "android-${_android_arch}-zlib")
options=(!strip !buildflags staticlibs !emptydirs)
makedepends=('android-pkg-config' 'yasm')
source=("http://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz"
@@ -44,12 +47,15 @@ build() {
;;
armv7a-eabi)
target_arch=arm
+ export LDFLAGS="-L${ANDROID_LIBS}/lib -ltheoraenc -ltheoradec -logg"
;;
x86)
target_arch=x86_32
+ export LDFLAGS="-L${ANDROID_LIBS}/lib -ltheoraenc -ltheoradec -logg"
;;
x86-64)
target_arch=x86_64
+ export LDFLAGS="-L${ANDROID_LIBS}/lib -ltheoraenc -ltheoradec -logg"
;;
esac
@@ -69,9 +75,9 @@ build() {
--nm=${ANDROID_NM}
--disable-debug
--enable-static
+ --enable-shared
--disable-stripping
--enable-gpl
- --enable-shared
--enable-version3
--enable-pic
--disable-doc
@@ -81,9 +87,11 @@ build() {
--disable-v4l2-m2m
--disable-indev=v4l2
--disable-outdev=v4l2
+ --enable-libtheora
--enable-libvorbis
--enable-libvpx
- --enable-libopus"
+ --enable-libopus
+ --enable-zlib"
# Platform specific patches
case "$_android_arch" in
diff --git a/android-env.sh b/android-env.sh
index 3549d530bb13..517f38e9b563 100755
--- a/android-env.sh
+++ b/android-env.sh
@@ -12,7 +12,7 @@ fi
# Minimum Android platform based on:
#
-# https://developer.android.com/about/dashboards/
+# http://gs.statcounter.com/os-version-market-share/android/mobile-tablet/worldwide
if [ -z "${ANDROID_MINIMUM_PLATFORM}" ]; then
export ANDROID_MINIMUM_PLATFORM=22
fi