diff options
author | Gonzalo Exequiel Pedone | 2024-03-03 00:09:09 -0300 |
---|---|---|
committer | Gonzalo Exequiel Pedone | 2024-03-03 00:09:09 -0300 |
commit | bdf487cd44c8a1340daa1b8b9c4afa541cd638be (patch) | |
tree | 9c01fe04d3da51d1dfc2cf3421d6ccb4ce955175 | |
parent | fe1840fe9eb02af352838128b0129d9649c48d56 (diff) | |
download | aur-bdf487cd44c8a1340daa1b8b9c4afa541cd638be.tar.gz |
Remove all references to -lpthread.
-rw-r--r-- | .SRCINFO | 2 | ||||
-rw-r--r-- | PKGBUILD | 20 |
2 files changed, 20 insertions, 2 deletions
@@ -1,7 +1,7 @@ pkgbase = android-x86-64-hwloc pkgdesc = Portable Hardware Locality is a portable abstraction of hierarchical architectures (android) pkgver = 2.10.0 - pkgrel = 1 + pkgrel = 2 url = https://www.open-mpi.org/projects/hwloc/ arch = any license = BSD @@ -8,7 +8,7 @@ _android_arch=x86-64 pkgname=android-${_android_arch}-hwloc pkgver=2.10.0 -pkgrel=1 +pkgrel=2 arch=('any') pkgdesc='Portable Hardware Locality is a portable abstraction of hierarchical architectures (android)' url='https://www.open-mpi.org/projects/hwloc/' @@ -27,6 +27,24 @@ options=(!strip !buildflags staticlibs !emptydirs) source=("https://www.open-mpi.org/software/hwloc/v${pkgver%.*}/downloads/hwloc-${pkgver}.tar.bz2") sha256sums=('0305dd60c9de2fbe6519fe2a4e8fdc6d3db8de574a0ca7812b92e80c05ae1392') +prepare() { + cd "${srcdir}/hwloc-${pkgver}" + + # Remove all references to -lpthread + + sed -i 's|-lpthread||g' hwloc/Makefile.am + sed -i 's|-lpthread||g' hwloc/Makefile.in + sed -i 's|HWLOC_LIBS_PRIVATE -lpthread|HWLOC_LIBS_PRIVATE|g' configure + sed -i 's|LIBS -lpthread|LIBS|g' configure + sed -i 's|HWLOC_LIBS -lpthread|HWLOC_LIBS|g' configure + sed -i 's|LIBS="-lpthread|LIBS="|g' configure + sed -i 's|-lpthread||g' tests/hwloc/Makefile.am + sed -i 's|-lpthread||g' tests/hwloc/Makefile.in + sed -i 's|HWLOC_LIBS_PRIVATE -lpthread|HWLOC_LIBS_PRIVATE|g' config/hwloc.m4 + sed -i 's|LIBS -lpthread|LIBS|g' config/hwloc.m4 + sed -i 's|HWLOC_LIBS -lpthread|HWLOC_LIBS|g' config/hwloc.m4 +} + build() { cd "${srcdir}/hwloc-${pkgver}" source android-env ${_android_arch} |