summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-02-17 18:48:49 -0300
committerGonzalo Exequiel Pedone2024-02-17 18:48:49 -0300
commit520de662212dd24b3d2c22501fdf6479d8da2d30 (patch)
treed1ab29c7b73ca7a60a95841de4ddafd9aa0961f2
downloadaur-520de662212dd24b3d2c22501fdf6479d8da2d30.tar.gz
New package.
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD52
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6c9afe645a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = android-x86-64-libidn2
+ pkgdesc = A free software implementation of IDNA2008 (mingw-w64)
+ pkgver = 2.3.4
+ pkgrel = 1
+ url = http://www.gnu.org/software/libidn
+ arch = any
+ license = GPL3, LGPL3
+ makedepends = android-configure
+ depends = android-x86-64-libunistring
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://ftp.gnu.org/pub/gnu/libidn/libidn2-2.3.4.tar.gz
+ sha256sums = 93caba72b4e051d1f8d4f5a076ab63c99b77faee019b72b9783b267986dbb45f
+
+pkgname = android-x86-64-libidn2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f3ed6a151b9f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+glib/
+pkg/
+src/
+*.log
+*.tar
+*.xz
+*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13e9cf407a1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+# Contributor: drakkan <nicola.murino at gmail dot com>
+
+_android_arch=x86-64
+
+pkgname=android-${_android_arch}-libidn2
+pkgver=2.3.4
+pkgrel=1
+arch=('any')
+pkgdesc="A free software implementation of IDNA2008 (mingw-w64)"
+url="http://www.gnu.org/software/libidn"
+license=("GPL3, LGPL3")
+depends=("android-${_android_arch}-libunistring")
+makedepends=('android-configure')
+options=(!strip !buildflags staticlibs !emptydirs)
+source=("https://ftp.gnu.org/pub/gnu/libidn/libidn2-${pkgver}.tar.gz")
+sha256sums=('93caba72b4e051d1f8d4f5a076ab63c99b77faee019b72b9783b267986dbb45f')
+
+build() {
+ cd "${srcdir}/libidn2-${pkgver}"
+ source android-env ${_android_arch}
+
+ export CFLAGS+=" -D__USE_FORTIFY_LEVEL=2"
+ export CXXFLAGS+=" -D__USE_FORTIFY_LEVEL=2"
+ export LDFLAGS+=" -Wl,--undefined-version"
+
+ extra_opts=
+
+ # Platform specific patches
+ case "$_android_arch" in
+ aarch64)
+ extra_opts=--with-included-libunistring
+ ;;
+ *)
+ ;;
+ esac
+
+ android-${_android_arch}-configure \
+ ${extra_opts} \
+ --disable-doc
+ make $MAKEFLAGS
+}
+
+package() {
+ cd "${srcdir}/libidn2-${pkgver}"
+ source android-env ${_android_arch}
+
+ make DESTDIR="$pkgdir" install
+ rm -rf "$pkgdir/${ANDROID_PREFIX_BIN}"
+ ${ANDROID_STRIP} -g "$pkgdir"/${ANDROID_PREFIX_LIB}/*.a || true
+ ${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}"/${ANDROID_PREFIX_LIB}/*.so
+}