summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-02-26 16:01:44 -0300
committerGonzalo Exequiel Pedone2024-02-26 16:01:44 -0300
commitb2f9cae6a7964321ddceebde2c7d7948fe9cc58c (patch)
tree84feffa5f96586d495414b9e36a10689490b77ce
downloadaur-b2f9cae6a7964321ddceebde2c7d7948fe9cc58c.tar.gz
New package.
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD36
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..362f03fa6333
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = android-x86-64-libksba
+ pkgdesc = A CMS and X.509 access library (android)
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = https://www.gnupg.org/related_software/libksba/index.html
+ arch = any
+ license = GPL
+ makedepends = android-configure
+ depends = android-x86-64-libgpg-error
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://gnupg.org/ftp/gcrypt/libksba/libksba-1.5.0.tar.bz2
+ sha256sums = ae4af129216b2d7fdea0b5bf2a788cd458a79c983bb09a43f4d525cc87aba0ba
+
+pkgname = android-x86-64-libksba
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..188dde609b65
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+pkg
+src
+*.tar.xz
+*.tar.gz
+*.tar.bz2
+*.tar.zst
+*.asc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63d0e5f3ab3d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+# Contributor: Andrew Sun <adsun701 at gmail dot com>
+
+_android_arch=x86-64
+
+pkgname=android-${_android_arch}-libksba
+pkgver=1.5.0
+pkgrel=1
+arch=('any')
+pkgdesc="A CMS and X.509 access library (android)"
+url="https://www.gnupg.org/related_software/libksba/index.html"
+license=('GPL')
+depends=("android-${_android_arch}-libgpg-error")
+makedepends=('android-configure')
+options=(!strip !buildflags staticlibs !emptydirs)
+source=("https://gnupg.org/ftp/gcrypt/libksba/libksba-${pkgver}.tar.bz2")
+sha256sums=('ae4af129216b2d7fdea0b5bf2a788cd458a79c983bb09a43f4d525cc87aba0ba')
+
+build() {
+ cd "${srcdir}/libksba-${pkgver}/"
+ source android-env ${_android_arch}
+
+ android-${_android_arch}-configure \
+ --with-libgpg-error-prefix="${ANDROID_PREFIX}"
+ make $MAKEFLAGS
+}
+
+package() {
+ cd "${srcdir}/libksba-${pkgver}/"
+ source android-env ${_android_arch}
+
+ make DESTDIR="$pkgdir" install
+ rm -rf "${pkgdir}"/${ANDROID_PREFIX_SHARE}
+ ${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}"/${ANDROID_PREFIX_LIB}/*.so
+ ${ANDROID_STRIP} -g "$pkgdir"/${ANDROID_PREFIX_LIB}/*.a
+}