summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-04-26 17:59:22 -0300
committerGonzalo Exequiel Pedone2024-04-26 17:59:22 -0300
commit5142efd66ac117f40330aef1278d1fe62e110b31 (patch)
treecc65bec385cc1a08fea47da2de4fe5a5b21b1281
downloadaur-5142efd66ac117f40330aef1278d1fe62e110b31.tar.gz
New package.
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD46
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1cd24a88e1e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = android-x86-64-libsoxr
+ pkgdesc = The SoX Resampler library that aims to give fast and high quality results for any constant resampling ratio (Android x86-64)
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://sourceforge.net/p/soxr/wiki/Home/
+ arch = any
+ license = GPL
+ makedepends = android-cmake
+ depends = android-ndk
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://downloads.sourceforge.net/project/soxr/soxr-0.1.3-Source.tar.xz
+ md5sums = 3f16f4dcb35b471682d4321eda6f6c08
+
+pkgname = android-x86-64-libsoxr
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5b03b115225
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg
+src
+*.tar.xz
+*.tar.gz
+*.tar.bz2
+*.asc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1dedf49499d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Anatol Pomozov
+# Contributor: JSpaces <jspace@unseen.is>
+# Contributor: Triode <triode1@btinternet.com>
+
+_android_arch=x86-64
+
+pkgname=android-${_android_arch}-libsoxr
+pkgver=0.1.3
+pkgrel=1
+arch=('any')
+pkgdesc="The SoX Resampler library that aims to give fast and high quality results for any constant resampling ratio (Android ${_android_arch})"
+url='https://sourceforge.net/p/soxr/wiki/Home/'
+license=('GPL')
+depends=('android-ndk')
+makedepends=('android-cmake')
+options=(!strip !buildflags staticlibs !emptydirs)
+source=("https://downloads.sourceforge.net/project/soxr/soxr-$pkgver-Source.tar.xz")
+md5sums=('3f16f4dcb35b471682d4321eda6f6c08')
+
+build() {
+ cd "${srcdir}/soxr-${pkgver}-Source"
+ source android-env ${_android_arch}
+
+ android-${_android_arch}-cmake \
+ -S . \
+ -B build \
+ -DBUILD_EXAMPLES=OFF \
+ -DBUILD_SHARED_LIBS=ON \
+ -DWITH_AVFFT=OFF \
+ -DWITH_LSR_BINDINGS=ON \
+ -DWITH_OPENMP=ON \
+ -DWITH_PFFFT=ON \
+ -Wno-dev
+ make -C build $MAKEFLAGS
+}
+
+package() {
+ cd "${srcdir}/soxr-${pkgver}-Source"
+ source android-env ${_android_arch}
+
+ make -C build DESTDIR="$pkgdir" install
+ rm -rf "${pkgdir}/${ANDROID_PREFIX_SHARE}"
+ ${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}"/${ANDROID_PREFIX_LIB}/*.so
+}