summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-02-16 16:36:20 -0300
committerGonzalo Exequiel Pedone2024-02-16 16:36:20 -0300
commit51a55957a352f7ff3ad4ea5b5844bed8d49d55c7 (patch)
treee0ab357ec45e42015beb1d43b68f642e50f6146b
downloadaur-51a55957a352f7ff3ad4ea5b5844bed8d49d55c7.tar.gz
New package.
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore7
-rw-r--r--0001-Fix-missing-symbols.patch25
-rw-r--r--PKGBUILD53
4 files changed, 110 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd28f51a2c5b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = android-x86-64-libx11
+ pkgdesc = X11 client-side library (android)
+ pkgver = 1.8.7
+ pkgrel = 1
+ url = https://xorg.freedesktop.org/
+ arch = any
+ license = custom
+ makedepends = android-x86-64-xorg-util-macros
+ makedepends = android-x86-64-xtrans
+ depends = android-ndk
+ depends = android-x86-64-libxcb
+ depends = android-x86-64-xorgproto
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://xorg.freedesktop.org//releases/individual/lib/libX11-1.8.7.tar.xz
+ source = https://xorg.freedesktop.org//releases/individual/lib/libX11-1.8.7.tar.xz.sig
+ source = 0001-Fix-missing-symbols.patch
+ validpgpkeys = 4A193C06D35E7C670FA4EF0BA2FB9E081F2D130E
+ sha512sums = d53bfc18f38d339a6a695b09835b2ae96b323881678bfe7ddca697605e3bdf4102ff49cc3078880a6c55b5977fcdd0aadaf5429086132de3a5bda302f79a2fa6
+ sha512sums = SKIP
+ sha512sums = ff37be288378b1b0023f754ff52ec8b41bf3f1b0fc9d1f21f79472ea145172cee50211f1fbbf8de2c58693577e21e4fe70f6820d1d7ad3914a6f5e0d08e08bee
+
+pkgname = android-x86-64-libx11
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f3ed6a151b9f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+glib/
+pkg/
+src/
+*.log
+*.tar
+*.xz
+*.pkg.tar.zst
diff --git a/0001-Fix-missing-symbols.patch b/0001-Fix-missing-symbols.patch
new file mode 100644
index 000000000000..1c1e92a09f78
--- /dev/null
+++ b/0001-Fix-missing-symbols.patch
@@ -0,0 +1,25 @@
+--- a/src/xcb_io.c
++++ b/src/xcb_io.c
+@@ -24,6 +24,11 @@
+ #include <sys/select.h>
+ #endif
+
++struct _LockInfoRec;
++typedef struct _LockInfoRec *LockInfoPtr;
++extern LockInfoPtr *_Xglobal_lock_p;
++#define _Xglobal_lock (*_Xglobal_lock_p)
++
+ #define xcb_fail_assert(_message, _var) { \
+ unsigned int _var = 1; \
+ fprintf(stderr, "[xcb] Aborting, sorry about that.\n"); \
+--- a/src/XlibInt.c
++++ b/src/XlibInt.c
+@@ -132,6 +132,8 @@
+
+ #define POLLFD_CACHE_SIZE 5
+
++#define FIONREAD 0x541B
++
+ /* initialize the struct array passed to poll() below */
+ Bool _XPollfdCacheInit(
+ Display *dpy)
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2125b088f1d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+
+_android_arch=x86-64
+
+pkgname=android-${_android_arch}-libx11
+pkgver=1.8.7
+pkgrel=1
+arch=('any')
+pkgdesc="X11 client-side library (android)"
+url="https://xorg.freedesktop.org/"
+# keep xorgproto runtime dependency
+# https://lists.archlinux.org/pipermail/arch-dev-public/2019-December/029767.html
+depends=('android-ndk'
+ "android-${_android_arch}-libxcb"
+ "android-${_android_arch}-xorgproto")
+makedepends=("android-${_android_arch}-xorg-util-macros"
+ "android-${_android_arch}-xtrans")
+license=('custom')
+options=(!strip !buildflags staticlibs !emptydirs)
+source=(${url}/releases/individual/lib/libX11-${pkgver}.tar.xz{,.sig}
+ '0001-Fix-missing-symbols.patch')
+sha512sums=('d53bfc18f38d339a6a695b09835b2ae96b323881678bfe7ddca697605e3bdf4102ff49cc3078880a6c55b5977fcdd0aadaf5429086132de3a5bda302f79a2fa6'
+ 'SKIP'
+ 'ff37be288378b1b0023f754ff52ec8b41bf3f1b0fc9d1f21f79472ea145172cee50211f1fbbf8de2c58693577e21e4fe70f6820d1d7ad3914a6f5e0d08e08bee')
+validpgpkeys=('4A193C06D35E7C670FA4EF0BA2FB9E081F2D130E') # Alan Coopersmith <alanc@freedesktop.org>
+
+prepare() {
+ cd "$srcdir/libX11-${pkgver}"
+ patch -Np1 -i ../0001-Fix-missing-symbols.patch
+}
+
+build() {
+ cd "$srcdir/libX11-${pkgver}"
+ source android-env ${_android_arch}
+
+ android-${_android_arch}-configure \
+ --disable-xf86bigfont \
+ --disable-malloc0returnsnull \
+ --disable-xthreads
+ make $MAKEFLAGS
+}
+
+package() {
+ cd "$srcdir/libX11-${pkgver}"
+ source android-env ${_android_arch}
+
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}/${ANDROID_PREFIX_SHARE}/doc"
+ rm -rf "${pkgdir}/${ANDROID_PREFIX_SHARE}/man"
+ ${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}"/${ANDROID_PREFIX_LIB}/*.so
+ ${ANDROID_STRIP} -g "$pkgdir"/${ANDROID_PREFIX_LIB}/*.a
+}