summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-03-23 14:08:37 -0300
committerGonzalo Exequiel Pedone2024-03-23 14:08:37 -0300
commit8df768385e66fb5cfc8a5b267cc5e27f3d0efa32 (patch)
tree8f445a83f28e0d41e7c8134b4a6d2c4913db74a2
parentb7b3ef5e6115ef0f777597f4a7a4ae7a743de2d6 (diff)
downloadaur-8df768385e66fb5cfc8a5b267cc5e27f3d0efa32.tar.gz
Added missing headers.
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Add-missing-headers.patch10
-rw-r--r--PKGBUILD10
3 files changed, 20 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9a504609d1c..d2a991255671 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = android-x86-64-openldap
pkgdesc = Lightweight Directory Access Protocol (LDAP) (Android, x86-64)
pkgver = 2.6.7
- pkgrel = 1
+ pkgrel = 2
url = https://www.openldap.org/
arch = any
groups = android-openldap-bootstrap
@@ -18,6 +18,8 @@ pkgbase = android-x86-64-openldap
options = staticlibs
options = !emptydirs
source = https://www.openldap.org/software/download/OpenLDAP/openldap-release/openldap-2.6.7.tgz
+ source = 0001-Add-missing-headers.patch
sha256sums = cd775f625c944ed78a3da18a03b03b08eea73c8aabc97b41bb336e9a10954930
+ sha256sums = 0d8f2c1011678df0e42e9691ab66565ae1b45c9b97018a6069d57665392e2b0c
pkgname = android-x86-64-openldap
diff --git a/0001-Add-missing-headers.patch b/0001-Add-missing-headers.patch
new file mode 100644
index 000000000000..c5c59cd62ade
--- /dev/null
+++ b/0001-Add-missing-headers.patch
@@ -0,0 +1,10 @@
+--- a/libraries/liblutil/lockf.c
++++ b/libraries/liblutil/lockf.c
+@@ -29,6 +29,7 @@
+ #include "portable.h"
+
+ #include <stdio.h>
++#include <string.h>
+ #include <ac/unistd.h>
+
+ #undef LOCK_API
diff --git a/PKGBUILD b/PKGBUILD
index eaec51d26d47..f4e4e97a371c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _android_arch=x86-64
pkgname=android-${_android_arch}-openldap
pkgver=2.6.7
-pkgrel=1
+pkgrel=2
arch=('any')
pkgdesc="Lightweight Directory Access Protocol (LDAP) (Android, ${_android_arch})"
url="https://www.openldap.org/"
@@ -19,13 +19,17 @@ makedepends=('android-configure'
'util-linux'
'chrpath')
options=(!strip !buildflags staticlibs !emptydirs)
-source=("https://www.openldap.org/software/download/OpenLDAP/openldap-release/openldap-${pkgver}.tgz")
-sha256sums=('cd775f625c944ed78a3da18a03b03b08eea73c8aabc97b41bb336e9a10954930')
+source=("https://www.openldap.org/software/download/OpenLDAP/openldap-release/openldap-${pkgver}.tgz"
+ '0001-Add-missing-headers.patch')
+sha256sums=('cd775f625c944ed78a3da18a03b03b08eea73c8aabc97b41bb336e9a10954930'
+ '0d8f2c1011678df0e42e9691ab66565ae1b45c9b97018a6069d57665392e2b0c')
prepare() {
cd "${srcdir}/openldap-$pkgver"
source android-env ${_android_arch}
+ patch -Np1 -i ../0001-Add-missing-headers.patch
+
autoconf -fiv
}