summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-02-11 21:38:50 -0300
committerGonzalo Exequiel Pedone2024-02-11 21:38:50 -0300
commitfcc3c8ed0124b1326e868718434044a6d5e42c27 (patch)
tree7e9516d2cd3c28df4a179a2c0dbe4a6a5d56741f
parentce5c654bda47c9b63e6b928177d561a66380d78e (diff)
downloadaur-fcc3c8ed0124b1326e868718434044a6d5e42c27.tar.gz
Package updated.
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Fix-build.patch32
-rw-r--r--PKGBUILD18
3 files changed, 5 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e7772622a77..c4193813e3ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = android-x86-64-pixman
pkgdesc = The pixel-manipulation library for X and cairo (android)
pkgver = 0.42.2
- pkgrel = 1
+ pkgrel = 2
url = http://xorg.freedesktop.org
arch = any
license = custom
@@ -13,8 +13,6 @@ pkgbase = android-x86-64-pixman
options = staticlibs
options = !emptydirs
source = http://xorg.freedesktop.org/releases/individual/lib/pixman-0.42.2.tar.xz
- source = 0001-Fix-build.patch
sha512sums = 3476e2676e66756b1af61b1e532cd80c985c191fb7956eb01702b419726cce99e79163b7f287f74f66414680e7396d13c3fee525cd663f12b6ac4877070ff4e8
- sha512sums = b1dd14b99bb77779bc5e4b90a31dbbb19f3ae7016bbc28f9e99df0e40bbc2bf816aa6e8b556912e27a799fe49379edb3fd4de74ed6a9e1b386137b319e25b473
pkgname = android-x86-64-pixman
diff --git a/0001-Fix-build.patch b/0001-Fix-build.patch
deleted file mode 100644
index e6974adc87d7..000000000000
--- a/0001-Fix-build.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- a/meson.build 2024-02-11 15:24:28.360885940 -0300
-+++ b/meson.build 2024-02-11 15:35:47.106338627 -0300
-@@ -394,6 +394,13 @@
- config.set('PIXMAN_GNUPLOT', 1)
- endif
-
-+res = run_command('python3', '-c', 'import os; print(os.environ["LIBRARY_PATH"])')
-+library_path = []
-+
-+if res.returncode() == 0
-+ library_path = res.stdout().strip().split(':')
-+endif
-+
- if cc.get_id() != 'msvc'
- dep_openmp = dependency('openmp', required : get_option('openmp'))
- if dep_openmp.found()
-@@ -417,13 +424,13 @@
-
- dep_png = null_dep
- if not get_option('libpng').disabled()
-- dep_png = dependency('libpng', required : false)
-+ dep_png = cc.find_library('png', required: false, dirs: library_path)
-
- # We need to look for the right library to link to for libpng,
- # when looking for libpng manually
- foreach png_ver : [ '16', '15', '14', '13', '12', '10' ]
- if not dep_png.found()
-- dep_png = cc.find_library('libpng@0@'.format(png_ver), has_headers : ['png.h'], required : false)
-+ dep_png = cc.find_library('libpng@0@'.format(png_ver), has_headers : ['png.h'], required: false, dirs: library_path)
- endif
- endforeach
-
diff --git a/PKGBUILD b/PKGBUILD
index 36486186e99b..91aa3881d92e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _android_arch=x86-64
pkgname=android-${_android_arch}-pixman
pkgver=0.42.2
-pkgrel=1
+pkgrel=2
pkgdesc="The pixel-manipulation library for X and cairo (android)"
arch=('any')
url="http://xorg.freedesktop.org"
@@ -14,24 +14,14 @@ depends=('android-ndk')
options=(!strip !buildflags staticlibs !emptydirs)
makedepends=("android-meson"
"android-${_android_arch}-libpng")
-source=("http://xorg.freedesktop.org/releases/individual/lib/pixman-${pkgver}.tar.xz"
- '0001-Fix-build.patch')
-sha512sums=('3476e2676e66756b1af61b1e532cd80c985c191fb7956eb01702b419726cce99e79163b7f287f74f66414680e7396d13c3fee525cd663f12b6ac4877070ff4e8'
- 'b1dd14b99bb77779bc5e4b90a31dbbb19f3ae7016bbc28f9e99df0e40bbc2bf816aa6e8b556912e27a799fe49379edb3fd4de74ed6a9e1b386137b319e25b473')
-
-prepare() {
- cd "${srcdir}/pixman-${pkgver}"
- patch -Np1 -i ../0001-Fix-build.patch
-
- find . -type f -exec sed -i 's|#include <png\.h>|#include <libpng/png.h>|g' {} \;
-}
+source=("http://xorg.freedesktop.org/releases/individual/lib/pixman-${pkgver}.tar.xz")
+sha512sums=('3476e2676e66756b1af61b1e532cd80c985c191fb7956eb01702b419726cce99e79163b7f287f74f66414680e7396d13c3fee525cd663f12b6ac4877070ff4e8')
build() {
cd "${srcdir}/pixman-${pkgver}"
source android-env ${_android_arch}
- export C_INCLUDE_PATH="${ANDROID_PREFIX_INCLUDE}"
- export LIBRARY_PATH="${ANDROID_PREFIX_LIB}"
+ export C_INCLUDE_PATH="${ANDROID_PREFIX_INCLUDE}/libpng:${ANDROID_PREFIX_INCLUDE}"
android-${_android_arch}-meson build \
-D loongson-mmi=disabled \