summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-03-16 18:58:04 -0300
committerGonzalo Exequiel Pedone2024-03-16 18:58:04 -0300
commit06312661c125c924c4bf1f9563d1be3930ee0b4b (patch)
tree5a538d668f28066004f3abdb540c94e5f6a675a0
parent7e73733a61d5dd84c964b1740b9c8c675a6c0c14 (diff)
downloadaur-06312661c125c924c4bf1f9563d1be3930ee0b4b.tar.gz
Package updated.
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore2
-rw-r--r--0001-Fix-soname.patch24
-rw-r--r--0002-Remove-lpthread.patch14
-rw-r--r--0003-Do-not-replace-ftell-and-fseek.patch20
-rw-r--r--PKGBUILD32
6 files changed, 87 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 684e79ad07df..5b0b6032cc7f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = android-x86-64-x264-bootstrap
- pkgdesc = Free library for encoding H264/AVC video streams (android)
+ pkgdesc = Free library for encoding H264/AVC video streams (Android, x86-64)
pkgver = 157.r72db4377
pkgrel = 2
url = https://www.videolan.org/developers/x264.html
@@ -17,8 +17,12 @@ pkgbase = android-x86-64-x264-bootstrap
options = staticlibs
options = !emptydirs
source = git+https://code.videolan.org/videolan/x264.git#commit=72db437770fd1ce3961f624dd57a8e75ff65ae0b
- source = soname.patch
- md5sums = SKIP
+ source = 0001-Fix-soname.patch
+ source = 0002-Remove-lpthread.patch
+ source = 0003-Do-not-replace-ftell-and-fseek.patch
md5sums = SKIP
+ md5sums = e8322f7da77816cd721183ed42f8a1bc
+ md5sums = ef45412614fcd0fe1a186672fcbbf47d
+ md5sums = 8114198c19f2abd3503af34030604225
pkgname = android-x86-64-x264-bootstrap
diff --git a/.gitignore b/.gitignore
index 47731b2e7117..b98085e0ab41 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,5 @@ src
*.tar.xz
*.tar.gz
*.tar.bz2
+*.tar.zst
+x264
diff --git a/0001-Fix-soname.patch b/0001-Fix-soname.patch
new file mode 100644
index 000000000000..ee2139d7a785
--- /dev/null
+++ b/0001-Fix-soname.patch
@@ -0,0 +1,24 @@
+--- a/configure 2019-07-22 12:39:27.767668982 -0300
++++ b/configure 2019-07-22 12:51:12.107203568 -0300
+@@ -1512,8 +1512,8 @@
+ echo "SOFLAGS=-shared -Wl,-h,\$(SONAME) $SOFLAGS" >> config.mak
+ else
+ echo "SOSUFFIX=so" >> config.mak
+- echo "SONAME=libx264.so.$API" >> config.mak
+- echo "SOFLAGS=-shared -Wl,-soname,\$(SONAME) $SOFLAGS" >> config.mak
++ echo "SONAME=libx264.so" >> config.mak
++ echo "SOFLAGS=-shared $SOFLAGS" >> config.mak
+ fi
+ echo 'default: lib-shared' >> config.mak
+ echo 'install: install-lib-shared' >> config.mak
+
+--- a/Makefile 2019-07-22 12:39:27.737668862 -0300
++++ b/Makefile 2019-07-22 12:55:12.284852758 -0300
+@@ -398,7 +398,6 @@
+ $(INSTALL) -m 755 $(SONAME) $(DESTDIR)$(bindir)
+ $(INSTALL) -m 644 $(IMPLIBNAME) $(DESTDIR)$(libdir)
+ else ifneq ($(SONAME),)
+- ln -f -s $(SONAME) $(DESTDIR)$(libdir)/libx264.$(SOSUFFIX)
+ $(INSTALL) -m 755 $(SONAME) $(DESTDIR)$(libdir)
+ endif
+
diff --git a/0002-Remove-lpthread.patch b/0002-Remove-lpthread.patch
new file mode 100644
index 000000000000..67cbab5fce13
--- /dev/null
+++ b/0002-Remove-lpthread.patch
@@ -0,0 +1,14 @@
+--- a/configure
++++ b/configure
+@@ -1049,9 +1049,9 @@
+ cc_check pthread.h -lc "pthread_create(0,0,0,0);" && thread="posix" && libpthread="-lc"
+ ;;
+ *)
+- if cc_check pthread.h -lpthread "pthread_create(0,0,0,0);" ; then
++ if cc_check pthread.h "" "pthread_create(0,0,0,0);" ; then
+ thread="posix"
+- libpthread="-lpthread"
++ libpthread=""
+ else
+ cc_check pthread.h "" "pthread_create(0,0,0,0);" && thread="posix" && libpthread=""
+ fi
diff --git a/0003-Do-not-replace-ftell-and-fseek.patch b/0003-Do-not-replace-ftell-and-fseek.patch
new file mode 100644
index 000000000000..691514907a2c
--- /dev/null
+++ b/0003-Do-not-replace-ftell-and-fseek.patch
@@ -0,0 +1,20 @@
+--- a/configure
++++ b/configure
+@@ -1289,17 +1289,6 @@
+ cc_check '' -fno-zero-initialized-in-bss && CFLAGS="$CFLAGS -fno-zero-initialized-in-bss"
+ fi
+
+-if cc_check "stdio.h" "" "fseeko(stdin,0,0);" ; then
+- define fseek fseeko
+- define ftell ftello
+-elif cc_check "stdio.h" "" "fseeko64(stdin,0,0);" ; then
+- define fseek fseeko64
+- define ftell ftello64
+-elif cc_check "stdio.h" "" "_fseeki64(stdin,0,0);" ; then
+- define fseek _fseeki64
+- define ftell _ftelli64
+-fi
+-
+ if cc_check '' -Wshadow ; then
+ CFLAGS="-Wshadow $CFLAGS"
+ fi
diff --git a/PKGBUILD b/PKGBUILD
index 1a2fe5edbaa9..72158a3aa5cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,22 +6,28 @@ _android_arch=x86-64
pkgname=android-${_android_arch}-x264-bootstrap
pkgver=157.r72db4377
+_commit=72db437770fd1ce3961f624dd57a8e75ff65ae0b
pkgrel=2
arch=('any')
-pkgdesc='Free library for encoding H264/AVC video streams (android)'
+pkgdesc="Free library for encoding H264/AVC video streams (Android, ${_android_arch})"
license=('GPL')
url='https://www.videolan.org/developers/x264.html'
+groups=('android-x264-bootstrap')
depends=('android-ndk')
-groups=(android-x264-bootstrap)
-options=(!strip !buildflags staticlibs !emptydirs)
-makedepends=('android-configure' 'yasm' 'git')
+makedepends=('android-configure'
+ 'yasm'
+ 'git')
provides=(${pkgname%-bootstrap})
conflicts=(${pkgname%-bootstrap})
-_commit=72db437770fd1ce3961f624dd57a8e75ff65ae0b
+options=(!strip !buildflags staticlibs !emptydirs)
source=("git+https://code.videolan.org/videolan/x264.git#commit=${_commit}"
- 'soname.patch')
+ '0001-Fix-soname.patch'
+ '0002-Remove-lpthread.patch'
+ '0003-Do-not-replace-ftell-and-fseek.patch')
md5sums=('SKIP'
- 'SKIP')
+ 'e8322f7da77816cd721183ed42f8a1bc'
+ 'ef45412614fcd0fe1a186672fcbbf47d'
+ '8114198c19f2abd3503af34030604225')
pkgver() {
cd "${srcdir}"/x264
@@ -31,14 +37,15 @@ pkgver() {
}
prepare() {
- cd "${srcdir}"/x264
- patch -Np1 -i ../soname.patch
+ cd "${srcdir}/x264"
+ patch -Np1 -i ../0001-Fix-soname.patch
+ patch -Np1 -i ../0002-Remove-lpthread.patch
+ patch -Np1 -i ../0003-Do-not-replace-ftell-and-fseek.patch
}
build() {
- cd "${srcdir}"/x264
+ cd "${srcdir}/x264"
source android-env ${_android_arch}
- unset LDFLAGS CPPFLAGS
configue_opts="
--disable-cli"
@@ -64,10 +71,11 @@ build() {
}
package() {
- cd "${srcdir}"/x264
+ cd "${srcdir}/x264"
source android-env ${_android_arch}
make DESTDIR="$pkgdir" install
${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}"/${ANDROID_PREFIX_LIB}/*.so
${ANDROID_STRIP} -g "$pkgdir"/${ANDROID_PREFIX_LIB}/*.a
+ rm -rvf "$pkgdir/usr"
}