summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-02-14 21:15:18 -0300
committerGonzalo Exequiel Pedone2024-02-14 21:15:18 -0300
commit4c6e5178feecda90c93d2e9c4944e6b450ec4663 (patch)
tree240eca438e5e84ba60bea5916c68f4061ec5f4a6
downloadaur-4c6e5178feecda90c93d2e9c4944e6b450ec4663.tar.gz
New package.
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD30
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d4905541264
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = android-x86-64-xorg-util-macros
+ pkgdesc = X.Org Autotools macros
+ pkgver = 1.20.0
+ pkgrel = 1
+ url = https://xorg.freedesktop.org/
+ arch = any
+ license = custom
+ makedepends = android-configure
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://xorg.freedesktop.org//releases/individual/util/util-macros-1.20.0.tar.xz
+ sha512sums = 76caefb118bf1675d7b2b96e1bbb04eb9a320b02e120839e55a22ef98538ecf00d0e686a67186fc8fdc8492d277ffe3125ae8b7ac61ce4739edc0de3f468d2eb
+
+pkgname = android-x86-64-xorg-util-macros
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f3ed6a151b9f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+glib/
+pkg/
+src/
+*.log
+*.tar
+*.xz
+*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d82d56dca92f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+_android_arch=x86-64
+
+pkgname=android-${_android_arch}-xorg-util-macros
+pkgver=1.20.0
+pkgrel=1
+pkgdesc="X.Org Autotools macros"
+arch=('any')
+license=('custom')
+url="https://xorg.freedesktop.org/"
+options=(!strip !buildflags staticlibs !emptydirs)
+makedepends=('android-configure')
+source=("${url}/releases/individual/util/util-macros-${pkgver}.tar.xz")
+sha512sums=('76caefb118bf1675d7b2b96e1bbb04eb9a320b02e120839e55a22ef98538ecf00d0e686a67186fc8fdc8492d277ffe3125ae8b7ac61ce4739edc0de3f468d2eb')
+
+build() {
+ cd "util-macros-${pkgver}"
+
+ android-${_android_arch}-configure
+ make $MAKEFLAGS
+}
+
+package() {
+ cd "util-macros-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+}