summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-02-14 21:18:42 -0300
committerGonzalo Exequiel Pedone2024-02-14 21:18:42 -0300
commit16b6cc1b3bfbac16b4b00d868c7157e1bbbad481 (patch)
tree7608d517c6df19efc5bbc9f5bed1d2fe8c337b09
downloadaur-16b6cc1b3bfbac16b4b00d868c7157e1bbbad481.tar.gz
New package.
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD42
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1068a16c4f97
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = android-x86-64-xorgproto
+ pkgdesc = combined X.Org X11 Protocol headers (android)
+ pkgver = 2023.2
+ pkgrel = 1
+ url = https://xorg.freedesktop.org/
+ arch = any
+ license = custom
+ checkdepends = python-libevdev
+ makedepends = android-meson
+ makedepends = android-x86-64-xorg-util-macros
+ depends = android-ndk
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://xorg.freedesktop.org/archive/individual/proto/xorgproto-2023.2.tar.xz
+ source = https://xorg.freedesktop.org/archive/individual/proto/xorgproto-2023.2.tar.xz.sig
+ validpgpkeys = 67DC86F2623FC5FD4BB5225D14706DBE1E4B4540
+ sha512sums = af0a8c8094fc6a490a886a8c048175762b6334798f2e48b6f6e19a7bb39ddbef05fa1237c4e9d9f1d870d24f5ca7a7c463044c41ceebd108f8ab0816677a582d
+ sha512sums = SKIP
+
+pkgname = android-x86-64-xorgproto
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f3ed6a151b9f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+glib/
+pkg/
+src/
+*.log
+*.tar
+*.xz
+*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54c10d933af4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+# Contributor: AndyRTR <andyrtr@archlinux.org>
+
+_android_arch=x86-64
+
+# When releasing a xorgproto version with updated keysyms, rebuild libx11
+
+pkgname=android-${_android_arch}-xorgproto
+pkgver=2023.2
+pkgrel=1
+pkgdesc="combined X.Org X11 Protocol headers (android)"
+arch=('any')
+url="https://xorg.freedesktop.org/"
+license=('custom')
+depends=('android-ndk')
+options=(!strip !buildflags staticlibs !emptydirs)
+makedepends=('android-meson'
+ "android-${_android_arch}-xorg-util-macros")
+checkdepends=('python-libevdev')
+source=("https://xorg.freedesktop.org/archive/individual/proto/xorgproto-$pkgver.tar.xz"{,.sig})
+sha512sums=('af0a8c8094fc6a490a886a8c048175762b6334798f2e48b6f6e19a7bb39ddbef05fa1237c4e9d9f1d870d24f5ca7a7c463044c41ceebd108f8ab0816677a582d'
+ 'SKIP')
+validpgpkeys=('67DC86F2623FC5FD4BB5225D14706DBE1E4B4540') # "Olivier Fourdan <fourdan@xfce.org>"
+
+build() {
+ cd "${srcdir}"/xorgproto-${pkgver}
+ source android-env ${_android_arch}
+
+ android-${_android_arch}-meson build
+ ninja -C build
+}
+
+package() {
+ cd "${srcdir}"/xorgproto-${pkgver}
+ source android-env ${_android_arch}
+
+ DESTDIR="${pkgdir}" meson install -C build
+
+ # cleanup
+ rm -f "${pkgdir}"/${ANDROID_PREFIX_INCLUDE}/X11/extensions/apple*
+ rm -f "${pkgdir}"/${ANDROID_PREFIX_SHARE}/pkgconfig/applewmproto.pc
+}