summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-02-17 16:21:08 -0300
committerGonzalo Exequiel Pedone2024-02-17 16:21:08 -0300
commit3fdf8d65cfdf7bfe684acbba3fa35381611b29a4 (patch)
tree2e309e935fe16028540e13ac95ae92b600ac56b5
downloadaur-3fdf8d65cfdf7bfe684acbba3fa35381611b29a4.tar.gz
New package.
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD53
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c5a7030690d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = android-x86-64-zstd
+ pkgdesc = Zstandard - Fast real-time compression algorithm (android)
+ pkgver = 1.5.5
+ pkgrel = 1
+ url = http://www.zstd.net/
+ arch = any
+ license = BSD
+ license = GPL2
+ makedepends = android-cmake
+ depends = android-x86-64-zlib
+ depends = android-x86-64-xz
+ depends = android-x86-64-lz4
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://github.com/facebook/zstd/archive/refs/tags/v1.5.5.tar.gz
+ sha256sums = 98e9c3d949d1b924e28e01eccb7deed865eefebf25c2f21c702e5cd5b63b85e1
+
+pkgname = android-x86-64-zstd
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f3ed6a151b9f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+glib/
+pkg/
+src/
+*.log
+*.tar
+*.xz
+*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5430852193b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+# Contributor: seth <getchoo at tuta dot io>
+# Contributor: xantares
+
+_android_arch=x86-64
+
+pkgname=android-${_android_arch}-zstd
+_pkgname=zstd
+pkgver=1.5.5
+pkgrel=1
+arch=('any')
+pkgdesc="Zstandard - Fast real-time compression algorithm (android)"
+url="http://www.zstd.net/"
+license=('BSD' 'GPL2')
+depends=("android-${_android_arch}-zlib"
+ "android-${_android_arch}-xz"
+ "android-${_android_arch}-lz4")
+makedepends=('android-cmake')
+options=(!strip !buildflags staticlibs !emptydirs)
+source=("https://github.com/facebook/zstd/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('98e9c3d949d1b924e28e01eccb7deed865eefebf25c2f21c702e5cd5b63b85e1')
+
+build() {
+ cd "${srcdir}/zstd-${pkgver}"
+ source android-env ${_android_arch}
+
+ mkdir -p build && pushd build
+ android-${_android_arch}-cmake \
+ -S ../build/cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DZSTD_ZLIB_SUPPORT=ON \
+ -DZSTD_LZMA_SUPPORT=ON \
+ -DZSTD_LZ4_SUPPORT=ON \
+ -DZSTD_BUILD_CONTRIB=OFF \
+ -DZSTD_BUILD_TESTS=OFF \
+ -DZSTD_PROGRAMS_LINK_SHARED=OFF \
+ -DZSTD_BUILD_PROGRAMS=OFF
+ make $MAKEFLAGS
+ popd
+}
+
+package() {
+ cd "${srcdir}/zstd-${pkgver}"
+ source android-env ${_android_arch}
+
+ pushd build
+ make DESTDIR="${pkgdir}" install
+ popd
+
+ ${ANDROID_STRIP} -g "$pkgdir"/${ANDROID_PREFIX_LIB}/*.a || true
+ ${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}"/${ANDROID_PREFIX_LIB}/*.so
+}