summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2020-01-18 18:11:23 -0300
committerGonzalo Exequiel Pedone2020-01-18 18:11:23 -0300
commitbbfcff6f02ee2f24dea9638129f1b1612bf6c2a6 (patch)
tree166eb4291d2d7ed92b73477528980759a54005ae
parent94d9f1b67f3a3ddf84a12ce37a2cbf3de82a5a92 (diff)
downloadaur-bbfcff6f02ee2f24dea9638129f1b1612bf6c2a6.tar.gz
Added libssh support.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb2b58a59ab2..eacfffd1c081 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = android-x86-ffmpeg
pkgdesc = Complete solution to record, convert and stream audio and video (android)
pkgver = 4.2.2
- pkgrel = 1
+ pkgrel = 2
url = http://ffmpeg.org/
arch = any
license = GPL3
@@ -10,6 +10,7 @@ pkgbase = android-x86-ffmpeg
makedepends = yasm
depends = android-x86-bzip2
depends = android-x86-lame
+ depends = android-x86-libssh
depends = android-x86-libtheora
depends = android-x86-libvorbis
depends = android-x86-libvpx
diff --git a/PKGBUILD b/PKGBUILD
index d2b59a1ecd37..516e95364495 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,14 @@ _android_arch=x86
pkgname=android-${_android_arch}-ffmpeg
pkgver=4.2.2
-pkgrel=1
+pkgrel=2
pkgdesc="Complete solution to record, convert and stream audio and video (android)"
arch=('any')
url="http://ffmpeg.org/"
license=('GPL3')
depends=("android-${_android_arch}-bzip2"
"android-${_android_arch}-lame"
+ "android-${_android_arch}-libssh"
"android-${_android_arch}-libtheora"
"android-${_android_arch}-libvorbis"
"android-${_android_arch}-libvpx"
@@ -48,7 +49,7 @@ build() {
case "$_android_arch" in
aarch64)
target_arch=aarch64
- export LDFLAGS="-L${ANDROID_PREFIX_LIB} -lm -logg -lvorbis"
+ export LDFLAGS="-L${ANDROID_PREFIX_LIB} -lm -logg -lvorbis -lssh -lcrypto_1_1 -lssl_1_1"
;;
armv7a-eabi)
target_arch=arm
@@ -95,6 +96,7 @@ build() {
--enable-libmp3lame
--enable-libopus
--enable-libspeex
+ --enable-libssh
--enable-libtheora
--enable-libvorbis
--enable-libvpx