summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-02-18 16:46:43 -0300
committerGonzalo Exequiel Pedone2024-02-18 16:46:43 -0300
commit475682fea5ab7f26fcb0d07ddff20a0081d24f46 (patch)
tree96a5aa1cbcba668691a8b8c6a16b94c9c54fe1e2
downloadaur-475682fea5ab7f26fcb0d07ddff20a0081d24f46.tar.gz
New package.
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD38
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..223eac9ca6cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = android-x86-libnghttp2
+ pkgdesc = Framing layer of HTTP/2 is implemented as a reusable C library (mingw-w64)
+ pkgver = 1.58.0
+ pkgrel = 1
+ url = https://nghttp2.org/
+ arch = any
+ license = MIT
+ makedepends = android-configure
+ depends = android-ndk
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://github.com/nghttp2/nghttp2/releases/download/v1.58.0/nghttp2-1.58.0.tar.xz
+ sha256sums = 4a68a3040da92fd9872c056d0f6b0cd60de8410de10b578f8ade9ecc14d297e0
+
+pkgname = android-x86-libnghttp2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5b03b115225
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg
+src
+*.tar.xz
+*.tar.gz
+*.tar.bz2
+*.asc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88812ebcb01b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+# Contributor: drakkan <nicola.murino at gmail dot com>
+
+_android_arch=x86
+
+pkgname=android-${_android_arch}-libnghttp2
+pkgver=1.58.0
+pkgrel=1
+arch=('any')
+pkgdesc='Framing layer of HTTP/2 is implemented as a reusable C library (mingw-w64)'
+url='https://nghttp2.org/'
+license=('MIT')
+depends=('android-ndk')
+makedepends=('android-configure')
+options=(!strip !buildflags staticlibs !emptydirs)
+source=("https://github.com/nghttp2/nghttp2/releases/download/v$pkgver/nghttp2-$pkgver.tar.xz")
+sha256sums=('4a68a3040da92fd9872c056d0f6b0cd60de8410de10b578f8ade9ecc14d297e0')
+
+build() {
+ cd "${srcdir}/nghttp2-$pkgver"
+ source android-env ${_android_arch}
+
+ android-${_android_arch}-configure \
+ --disable-examples \
+ --enable-lib-only
+ make $MAKEFLAGS
+}
+
+package() {
+ cd "${srcdir}/nghttp2-$pkgver"
+ source android-env ${_android_arch}
+
+ make DESTDIR="$pkgdir" install
+ rm -rf "${pkgdir}/${ANDROID_PREFIX_SHARE}/doc"
+ rm -rf "${pkgdir}/${ANDROID_PREFIX_SHARE}/man"
+ ${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}"/${ANDROID_PREFIX_LIB}/*.so
+ ${ANDROID_STRIP} -g "$pkgdir"/${ANDROID_PREFIX_LIB}/*.a
+}