summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-02-16 19:29:15 -0300
committerGonzalo Exequiel Pedone2024-02-16 19:29:15 -0300
commit5b6a3d9c817025f2ad91c41c10a2b5844916137d (patch)
tree7e8578f5585d2a917c6ba24ba83fbc61a51ff0e9
downloadaur-5b6a3d9c817025f2ad91c41c10a2b5844916137d.tar.gz
New package.
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD39
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c794478b7697
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = android-x86-libxrender
+ pkgdesc = X Rendering Extension client library
+ pkgver = 0.9.11
+ pkgrel = 1
+ url = https://xorg.freedesktop.org/
+ arch = any
+ license = custom
+ makedepends = android-x86-xorgproto
+ depends = android-x86-libx11
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://xorg.freedesktop.org//archive/individual/lib/libXrender-0.9.11.tar.xz
+ source = https://xorg.freedesktop.org//archive/individual/lib/libXrender-0.9.11.tar.xz.sig
+ validpgpkeys = 4A193C06D35E7C670FA4EF0BA2FB9E081F2D130E
+ sha512sums = 2327cc1b530382d81df29b8d579f801f1f990202107cc84506986bcf5d15010d414e9418987b200e3f222d188afce46f0d7754febcdca62a5fc1e541b3bb82de
+ sha512sums = SKIP
+
+pkgname = android-x86-libxrender
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f3ed6a151b9f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+glib/
+pkg/
+src/
+*.log
+*.tar
+*.xz
+*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b9ec59ef2ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+# Controbutor: Jan de Groot <jgc@archlinux.org>
+
+_android_arch=x86
+
+pkgname=android-${_android_arch}-libxrender
+pkgver=0.9.11
+pkgrel=1
+arch=('any')
+pkgdesc="X Rendering Extension client library"
+url="https://xorg.freedesktop.org/"
+license=('custom')
+depends=("android-${_android_arch}-libx11")
+makedepends=("android-${_android_arch}-xorgproto")
+options=(!strip !buildflags staticlibs !emptydirs)
+source=(${url}/archive/individual/lib/libXrender-${pkgver}.tar.xz{,.sig})
+sha512sums=('2327cc1b530382d81df29b8d579f801f1f990202107cc84506986bcf5d15010d414e9418987b200e3f222d188afce46f0d7754febcdca62a5fc1e541b3bb82de'
+ 'SKIP')
+validpgpkeys=('4A193C06D35E7C670FA4EF0BA2FB9E081F2D130E') #Alan Coopersmith <alan.coopersmith@oracle.com>
+
+build() {
+ cd "$srcdir/libXrender-${pkgver}"
+ source android-env ${_android_arch}
+
+ android-${_android_arch}-configure \
+ --disable-malloc0returnsnull
+ make $MAKEFLAGS
+}
+
+package() {
+ cd "$srcdir/libXrender-${pkgver}"
+ source android-env ${_android_arch}
+
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}/${ANDROID_PREFIX_SHARE}"
+ ${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}"/${ANDROID_PREFIX_LIB}/*.so
+ ${ANDROID_STRIP} -g "$pkgdir"/${ANDROID_PREFIX_LIB}/*.a
+}