summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-05-04 12:02:29 -0300
committerGonzalo Exequiel Pedone2024-05-04 12:02:29 -0300
commit1c27c570a814fee2852a15722993751fb61af9a9 (patch)
treee86f3cc21ac5e4430cb1f4934868acc9ffd58bee
downloadaur-1c27c570a814fee2852a15722993751fb61af9a9.tar.gz
New package.
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD39
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5289ab41f5fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = android-x86-opencl-clhpp
+ pkgdesc = OpenCL C++ header files (Android x86)
+ pkgver = 2023.04.17
+ pkgrel = 1
+ url = https://github.com/KhronosGroup/OpenCL-CLHPP
+ arch = any
+ license = custom
+ makedepends = android-cmake
+ makedepends = android-x86-opencl-headers
+ depends = android-x86-opencl-headers
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://github.com/KhronosGroup/OpenCL-CLHPP/archive/v2023.04.17.tar.gz
+ sha256sums = 179243843c620ef6f78b52937aaaa0a742c6ff415f9aaefe3c20225ee283b357
+
+pkgname = android-x86-opencl-clhpp
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5b03b115225
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg
+src
+*.tar.xz
+*.tar.gz
+*.tar.bz2
+*.asc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..616fc65642ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+# Contributor: Laurent Carlier <lordheavym@gmail.com>
+
+_android_arch=x86
+
+pkgname=android-${_android_arch}-opencl-clhpp
+pkgver=2023.04.17
+pkgrel=1
+arch=('any')
+pkgdesc="OpenCL C++ header files (Android ${_android_arch})"
+url='https://github.com/KhronosGroup/OpenCL-CLHPP'
+license=('custom')
+depends=("android-${_android_arch}-opencl-headers")
+makedepends=('android-cmake'
+ "android-${_android_arch}-opencl-headers")
+options=(!strip !buildflags staticlibs !emptydirs)
+source=("https://github.com/KhronosGroup/OpenCL-CLHPP/archive/v${pkgver}.tar.gz")
+sha256sums=('179243843c620ef6f78b52937aaaa0a742c6ff415f9aaefe3c20225ee283b357')
+
+build() {
+ cd "${srcdir}/OpenCL-CLHPP-${pkgver}"
+ source android-env ${_android_arch}
+
+ android-${_android_arch}-cmake \
+ -S . \
+ -B build \
+ -DBUILD_EXAMPLES=OFF \
+ -DBUILD_DOCS=ON \
+ -DBUILD_TESTING=OFF \
+ -DOpenCLHeaders_DIR="${ANDROID_PREFIX_SHARE}/cmake/OpenCLHeaders"
+ make -C build $MAKEFLAGS
+}
+
+package() {
+ cd "${srcdir}/OpenCL-CLHPP-${pkgver}"
+ source android-env ${_android_arch}
+
+ make -C build DESTDIR="$pkgdir" install
+}