summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2019-04-24 18:56:14 -0300
committerGonzalo Exequiel Pedone2019-04-24 18:56:14 -0300
commita1625523dfd4057a1384028cf2b9e48ec236d615 (patch)
tree847e61bef08f165062be49b450cf4513fd78da27
parentca81e09d3dfd1385181d2266e710e68d9289deb7 (diff)
downloadaur-a1625523dfd4057a1384028cf2b9e48ec236d615.tar.gz
Package updated.
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD32
-rwxr-xr-xandroid-env.sh2
4 files changed, 20 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ee9fa392ea4..bd2acaa484f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
# Generated by mksrcinfo v8
-# lun abr 15 20:18:03 UTC 2019
+# miƩ abr 24 21:54:48 UTC 2019
pkgbase = android-x86-qt5
pkgdesc = Qt 5 for Android
- pkgver = 5.12.2
- pkgrel = 4
+ pkgver = 5.12.3
+ pkgrel = 1
url = https://www.qt.io
install = android-x86-qt5.install
- arch = x86_64
+ arch = any
groups = android-qt5
license = GPL3
license = LGPL
@@ -32,10 +32,10 @@ pkgbase = android-x86-qt5
options = !buildflags
options = staticlibs
options = !emptydirs
- source = http://download.qt-project.org/official_releases/qt/5.12/5.12.2/single/qt-everywhere-src-5.12.2.tar.xz
+ source = http://download.qt-project.org/official_releases/qt/5.12/5.12.3/single/qt-everywhere-src-5.12.3.tar.xz
source = 0001-Fix-clang-build.patch
source = 0002-Disable-mapbox.patch
- md5sums = 99c2eb46e533371798b4ca2d1458e065
+ md5sums = 38017e0ed88b9baba063bd723d9ca8b2
md5sums = 0b19ddef193baddb656d3170635e6de6
md5sums = 20d8bdd24102e9011b561b7361394728
diff --git a/.gitignore b/.gitignore
index b5bc2aa573e1..47731b2e7117 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@ pkg
src
*.tar.xz
*.tar.gz
+*.tar.bz2
diff --git a/PKGBUILD b/PKGBUILD
index 5f4d01ff83f6..ef95f5036c05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,10 +9,10 @@ _android_arch=x86
source android-env.sh ${_android_arch}
pkgname=android-${_android_arch}-qt5
-pkgver=5.12.2
-pkgrel=4
+pkgver=5.12.3
+pkgrel=1
pkgdesc="Qt 5 for Android"
-arch=('x86_64')
+arch=('any')
url='https://www.qt.io'
license=('GPL3' 'LGPL')
makedepends=('libgl'
@@ -23,22 +23,14 @@ makedepends=('libgl'
'gperf'
'libxslt'
'fontconfig')
-
-if [ -z "${ANDROID_NO_DEPS}" ]; then
- depends=('java-runtime-headless-openjdk<=8'
- 'apache-ant'
- 'android-pkg-config'
- 'android-ndk'
- "android-platform-$ANDROID_MINIMUM_PLATFORM"
- 'android-sdk'
- 'android-sdk-build-tools'
- 'android-sdk-platform-tools')
-else
- depends=('java-runtime-headless-openjdk<=8'
- 'apache-ant'
- 'android-pkg-config')
-fi
-
+depends=('java-runtime-headless-openjdk<=8'
+ 'apache-ant'
+ 'android-pkg-config'
+ 'android-ndk'
+ "android-platform-$ANDROID_MINIMUM_PLATFORM"
+ 'android-sdk'
+ 'android-sdk-build-tools'
+ 'android-sdk-platform-tools')
groups=('android-qt5')
case "$_android_arch" in
@@ -68,7 +60,7 @@ install="${pkgname}.install"
source=("http://download.qt-project.org/official_releases/qt/${pkgver:0:4}/${pkgver}/single/${_pkgfqn}.tar.xz"
"0001-Fix-clang-build.patch"
"0002-Disable-mapbox.patch")
-md5sums=('99c2eb46e533371798b4ca2d1458e065'
+md5sums=('38017e0ed88b9baba063bd723d9ca8b2'
'0b19ddef193baddb656d3170635e6de6'
'20d8bdd24102e9011b561b7361394728')
diff --git a/android-env.sh b/android-env.sh
index 3549d530bb13..517f38e9b563 100755
--- a/android-env.sh
+++ b/android-env.sh
@@ -12,7 +12,7 @@ fi
# Minimum Android platform based on:
#
-# https://developer.android.com/about/dashboards/
+# http://gs.statcounter.com/os-version-market-share/android/mobile-tablet/worldwide
if [ -z "${ANDROID_MINIMUM_PLATFORM}" ]; then
export ANDROID_MINIMUM_PLATFORM=22
fi