summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-08-12 10:07:10 +1200
committercaltlgin2020-08-12 10:07:10 +1200
commit3cc7f68a168d35ea01164875f0b47d65d560e64f (patch)
tree29b94eca143a0da5e09d40c89f55171b507d71a6
parentdf2ebe94bcbde4c0ec44e47c277c5acc4caa95ec (diff)
downloadaur-3cc7f68a168d35ea01164875f0b47d65d560e64f.tar.gz
Clean PKGBUILD
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 88c53223ed76..f647bee38a39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,15 +24,17 @@ build() {
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ export GOPATH="${srcdir}"
cd "${_pkgname}"
go build -v -o "${_pkgname}" main.go
}
package() {
- install -Dm755 "${_pkgname}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
- install -Dm644 "${_pkgname}/README.mkd" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
- install -Dm644 "${_pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ cd "${_pkgname}"
+ install -Dm755 -t "${pkgdir}/usr/bin" "${_pkgname}"
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" 'README.mkd'
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${_pkgname}" 'LICENSE'
}
# vim: ts=2 sw=2 et: