summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHilton Medeiros2016-02-27 11:28:35 -0300
committerHilton Medeiros2016-02-27 11:28:35 -0300
commit616cab702c4222fc6e38167020b8725ce9531045 (patch)
tree0b4c768ff2fe72b863521a62a53d2e42b81b8ab3
downloadaur-616cab702c4222fc6e38167020b8725ce9531045.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD40
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5da6fd0968bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Feb 27 14:24:19 UTC 2016
+pkgbase = angelscript
+ pkgdesc = An extremely flexible cross-platform scripting library.
+ pkgver = 2.31.0
+ pkgrel = 1
+ url = http://angelcode.com/angelscript/
+ arch = i686
+ arch = x86_64
+ license = custom:ZLIB
+ depends = gcc-libs
+ source = http://angelcode.com/angelscript/sdk/files/angelscript_2.31.0.zip
+ source = LICENSE
+ sha512sums = a415c9c9ee9bc2ab0eecd0c7a41ef173f6616f393dd092143e4be2c4eddf6394f065d0862c0603015426681648ff1f7c0aaf121036ca13065f495beaed112e98
+ sha512sums = 523a6ded94dab26ebc1fc5ed39346b950afea1dae1a51c5f262242de1ad86ce921d462b430825bd7a0ca7bb2d501b85e60f39732c3e1d948e1f0182cc9c691a1
+
+pkgname = angelscript
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..0597a2224bee
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+AngelCode Scripting Library
+Copyright (c) 2003-2016 Andreas Jonsson
+
+This software is provided 'as-is', without any express or implied
+warranty. In no event will the authors be held liable for any
+damages arising from the use of this software.
+
+Permission is granted to anyone to use this software for any
+purpose, including commercial applications, and to alter it and
+redistribute it freely, subject to the following restrictions:
+
+1. The origin of this software must not be misrepresented; you
+must not claim that you wrote the original software. If you use
+this software in a product, an acknowledgment in the product
+documentation would be appreciated but is not required.
+
+2. Altered source versions must be plainly marked as such, and
+must not be misrepresented as being the original software.
+
+3. This notice may not be removed or altered from any source
+distribution.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7f6908a58a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Hilton Medeiros <medeiros.hilton@gmail.com>
+
+pkgname=angelscript
+pkgver=2.31.0
+pkgrel=1
+pkgdesc="An extremely flexible cross-platform scripting library."
+arch=('i686' 'x86_64')
+url="http://angelcode.com/angelscript/"
+license=('custom:ZLIB')
+depends=('gcc-libs')
+source=("http://angelcode.com/angelscript/sdk/files/${pkgname}_${pkgver}.zip"
+ LICENSE)
+sha512sums=('a415c9c9ee9bc2ab0eecd0c7a41ef173f6616f393dd092143e4be2c4eddf6394f065d0862c0603015426681648ff1f7c0aaf121036ca13065f495beaed112e98'
+ '523a6ded94dab26ebc1fc5ed39346b950afea1dae1a51c5f262242de1ad86ce921d462b430825bd7a0ca7bb2d501b85e60f39732c3e1d948e1f0182cc9c691a1')
+
+build() {
+ cd "$srcdir/sdk/angelscript/projects/gnuc"
+
+ make all
+}
+
+package() {
+ cd "$srcdir/sdk/angelscript/projects/gnuc"
+
+ install -d "$pkgdir"/usr/share/{licenses,doc}/$pkgname \
+ "$pkgdir"/usr/share/$pkgname \
+ "$pkgdir"/usr/share/doc/$pkgname/articles
+
+ make PREFIX="/usr" DESTDIR="$pkgdir" install
+
+ msg "Installing add-ons..."
+ cd "$srcdir/sdk"
+ cp -rf add_on "$pkgdir/usr/share/$pkgname/"
+
+ msg "Installing documentation and license..."
+ cd "$srcdir/sdk/docs"
+ cp -rf * "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
+}
+