summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Wojdyla2020-08-24 04:19:49 +0200
committerMichal Wojdyla2020-08-24 04:19:49 +0200
commit6caa0587656ce8f275e20e70f2ffcabeef926531 (patch)
treee5c91283bacd5c7e088ebfed6fd0c43082793534
downloadaur-angelscript-2.31.2.tar.gz
upload
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD40
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..661a600e48f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = angelscript-2.31.2
+ pkgdesc = An extremely flexible cross-platform scripting library. - Specific version for Rigs of Rods
+ pkgver = 2.31.2
+ pkgrel = 1
+ url = https://angelcode.com/angelscript/
+ arch = i686
+ arch = x86_64
+ license = custom:ZLIB
+ depends = gcc-libs
+ conflicts = angelscript
+ source = http://angelcode.com/angelscript/sdk/files/angelscript_2.31.2.zip
+ source = LICENSE
+ sha512sums = 4dd4c64caf4fc66a9fbda55d0fb81b91a6af5f5d4f28728343ff06455418ebaf5a36895e04e0bc2aebd76b510e81357f7e0ffd7e575b49bbc9573c106f24b265
+ sha512sums = 523a6ded94dab26ebc1fc5ed39346b950afea1dae1a51c5f262242de1ad86ce921d462b430825bd7a0ca7bb2d501b85e60f39732c3e1d948e1f0182cc9c691a1
+
+pkgname = angelscript-2.31.2
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..0597a2224bee
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+AngelCode Scripting Library
+Copyright (c) 2003-2016 Andreas Jonsson
+
+This software is provided 'as-is', without any express or implied
+warranty. In no event will the authors be held liable for any
+damages arising from the use of this software.
+
+Permission is granted to anyone to use this software for any
+purpose, including commercial applications, and to alter it and
+redistribute it freely, subject to the following restrictions:
+
+1. The origin of this software must not be misrepresented; you
+must not claim that you wrote the original software. If you use
+this software in a product, an acknowledgment in the product
+documentation would be appreciated but is not required.
+
+2. Altered source versions must be plainly marked as such, and
+must not be misrepresented as being the original software.
+
+3. This notice may not be removed or altered from any source
+distribution.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7973c2721284
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Michal Wojdyla < micwoj9292 at gmail dot com >
+
+pkgname=angelscript-2.31.2
+pkgver=2.31.2
+pkgrel=1
+pkgdesc="An extremely flexible cross-platform scripting library. - Specific version for Rigs of Rods"
+arch=('i686' 'x86_64')
+url="https://angelcode.com/angelscript/"
+license=('custom:ZLIB')
+depends=('gcc-libs')
+conflicts=("angelscript")
+source=("http://angelcode.com/angelscript/sdk/files/angelscript_$pkgver.zip"
+ LICENSE)
+sha512sums=('4dd4c64caf4fc66a9fbda55d0fb81b91a6af5f5d4f28728343ff06455418ebaf5a36895e04e0bc2aebd76b510e81357f7e0ffd7e575b49bbc9573c106f24b265'
+ '523a6ded94dab26ebc1fc5ed39346b950afea1dae1a51c5f262242de1ad86ce921d462b430825bd7a0ca7bb2d501b85e60f39732c3e1d948e1f0182cc9c691a1')
+
+build() {
+ cd "$srcdir/sdk/angelscript/projects/gnuc"
+
+ make all
+}
+
+package() {
+ cd "$srcdir/sdk/angelscript/projects/gnuc"
+
+ install -d "$pkgdir"/usr/share/{licenses,doc}/$pkgname \
+ "$pkgdir"/usr/share/$pkgname \
+ "$pkgdir"/usr/share/doc/$pkgname/articles
+
+ make PREFIX="/usr" DESTDIR="$pkgdir" install
+
+ msg "Installing add-ons..."
+ cd "$srcdir/sdk"
+ cp -rf add_on "$pkgdir/usr/share/$pkgname/"
+
+ msg "Installing documentation and license..."
+ cd "$srcdir/sdk/docs"
+ cp -rf * "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
+}