summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Sampson2015-06-21 20:06:15 +1000
committerMike Sampson2015-06-21 20:06:15 +1000
commitac36e53dd83f4636be2686ee4ffaa306ae6e6bce (patch)
tree54c7320d1fe037f789a16df34442542a22badff9
downloadaur-angrydd.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD33
-rw-r--r--angrydd.desktop7
4 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5343c9728907
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = angrydd
+ pkgdesc = "Angry, Drunken Dwarves" is a classic "falling blocks" puzzle game
+ pkgver = 1.0.1
+ pkgrel = 6
+ url = http://www.sacredchao.net/~piman/angrydd/
+ arch = any
+ license = GPL
+ license = custom
+ depends = python2-pygame>=1.6.2
+ depends = python2-numpy
+ source = http://www.sacredchao.net/~piman/angrydd//angrydd-1.0.1.tar.gz
+ source = angrydd.desktop
+ source = LICENSE
+ md5sums = 3b0f9771eaae3ffb23d13576a54075e9
+ md5sums = 4e26bb276083c699df425770e0fc451b
+ md5sums = 04f141a60ab1c9aeef6341227618f39d
+
+pkgname = angrydd
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..bdb1d408f618
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+death.wav: Copyright 2003 Manuel Moss (http://armagetron.sf.net/)
+break.wav: Copyright 2003 John-Paul Gignac (http://pathological.sf.net)
+gameover.wav: Copyright 2002 Pete Shinners (http://www.pygame.org)
+
+pickaxe.svg: Copyright 2004 Jenn Hartnoll
+diamond1.svg: Copyright 2004 Michael Urman
+Character portraits: Copyright 2004 Jessi Silver
+
+intro.ogg: Copyright 2004 Brendan Becker
+single.ogg, versus-1.ogg: Copyright 2005 Ben Zeigler
+
+clicked.wav, rotate.wav, select-confirm.wav, select-move.wav,
+and tick.wav: Released into the public domain. If this is not allowed
+in your jurisdiction, you may freely copy, distribute, modify, and
+distribute modified versions of these files, for any purpose.
+
+All else: Copyright 2004 Joe Wreschnig <piman@sacredchao.net>
+
+Unless otherwise noted above, all material (source code, documentation,
+and game data) is licensed under the GNU GPL version 2 as published by
+the Free Software Foundation, copyrighted by the owners credited above.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f6ae4a8a480
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Mike Sampson <mike at sambodata dot com>
+# Contributor: rabyte <rabyte*gmail>
+# Contributor: mpie <michael.kyne-phillips1@ntlworld.com>
+
+pkgname=angrydd
+pkgver=1.0.1
+pkgrel=6
+pkgdesc='"Angry, Drunken Dwarves" is a classic "falling blocks" puzzle game'
+arch=('any')
+url="http://www.sacredchao.net/~piman/$pkgname/"
+license=('GPL' 'custom')
+depends=('python2-pygame>=1.6.2' 'python2-numpy')
+[ "$CARCH" = "i686" ] && optdepends=('psyco: improved loading times')
+source=($url/$pkgname-$pkgver.tar.gz \
+ $pkgname.desktop
+ LICENSE)
+md5sums=('3b0f9771eaae3ffb23d13576a54075e9'
+ '4e26bb276083c699df425770e0fc451b'
+ '04f141a60ab1c9aeef6341227618f39d')
+
+build() {
+ cd $pkgname-$pkgver
+
+ make PREFIX=/usr DESTDIR="$pkgdir" TO=share/angrydd install
+
+ sed -i -e "s|env python$|env python2|" ${pkgdir}/usr/share/angrydd/angrydd.py
+
+ mv -f "$pkgdir"/usr/games/ "$pkgdir"/usr/bin/
+
+ install -Dm644 $pkgname.png "$pkgdir"/usr/share/pixmaps/$pkgname.png
+ install -Dm644 ../$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+ install -Dm644 ../LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/angrydd.desktop b/angrydd.desktop
new file mode 100644
index 000000000000..5e14957ff92a
--- /dev/null
+++ b/angrydd.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Angry Drunken Dwarves
+Exec=angrydd
+Icon=angrydd
+Type=Application
+Comment=Classic "falling blocks" puzzle game
+Categories=Game;LogicGame;