summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-02-22 17:13:15 -0700
committerMark Wagie2021-02-22 17:13:15 -0700
commit06033ceb120e21955b0696633ab3d6fdf80d2849 (patch)
tree2b297b6290c5e755e0c7c6e8d91f99a76cef25da
parent85c6d1a098da6baf9424216efa493d29efc8d8ee (diff)
downloadaur-06033ceb120e21955b0696633ab3d6fdf80d2849.tar.gz
1.0.2
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD56
3 files changed, 43 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae3b6a8f06c3..46e0331281a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
-# Generated by makepkg 5.0.2
-# Thu Aug 10 20:14:46 UTC 2017
pkgbase = angrysearch
- pkgdesc = Instant file search
- pkgver = 1.0.1
+ pkgdesc = Linux file search, instant results as you type
+ pkgver = 1.0.2
pkgrel = 1
- url = https://github.com/dotheevo/angrysearch/
+ url = https://github.com/DoTheEvo/ANGRYsearch
arch = any
- license = GPL
+ license = GPL2
+ makedepends = git
depends = python-pyqt5
depends = libxkbcommon-x11
depends = xdg-utils
optdepends = python-gobject: desktop notifications support
optdepends = xdotool: Thunar & PCmanFM to select file on path open
- source = https://github.com/DoTheEvo/ANGRYsearch/archive/v1.0.1.tar.gz
- sha256sums = 9a550649c3efafb26660860758f2e75702ce96a0a0c50dc34ced2967b51a843f
+ source = git+https://github.com/DoTheEvo/ANGRYsearch.git#commit=00d8d0f24a30bbba231605a41add908f36e1ae81
+ sha256sums = SKIP
pkgname = angrysearch
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 8c82cd28d2d3..a62e0987b0b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,34 @@
-# Maintainer: DoTheEvolution <DoTheEvo@gmail.com>
-pkgname="angrysearch"
-pkgver=1.0.1
+# Maintainer:
+# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: DoTheEvolution <DoTheEvo@gmail.com>
+pkgname=angrysearch
+pkgver=1.0.2
pkgrel=1
-pkgdesc="Instant file search"
-arch=("any")
-url="https://github.com/dotheevo/angrysearch/"
-license=("GPL")
-depends=("python-pyqt5" "libxkbcommon-x11" "xdg-utils")
-optdepends=("python-gobject: desktop notifications support"
- "xdotool: Thunar & PCmanFM to select file on path open")
-source=("https://github.com/DoTheEvo/ANGRYsearch/archive/v$pkgver.tar.gz")
-sha256sums=("9a550649c3efafb26660860758f2e75702ce96a0a0c50dc34ced2967b51a843f")
+pkgdesc="Linux file search, instant results as you type"
+arch=('any')
+url="https://github.com/DoTheEvo/ANGRYsearch"
+license=('GPL2')
+depends=('python-pyqt5' 'libxkbcommon-x11' 'xdg-utils')
+makedepends=('git')
+optdepends=('python-gobject: desktop notifications support'
+ 'xdotool: Thunar & PCmanFM to select file on path open')
+_commit=00d8d0f24a30bbba231605a41add908f36e1ae81
+source=("git+https://github.com/DoTheEvo/ANGRYsearch.git#commit=$_commit")
+#source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('SKIP')
-package() {
- cd "ANGRYsearch-$pkgver"
- install -Dm755 angrysearch.py "$pkgdir/usr/share/angrysearch/angrysearch.py"
- install -Dm755 angrysearch_update_database.py "$pkgdir/usr/share/angrysearch/angrysearch_update_database.py"
- install -Dm644 angrysearch.desktop "$pkgdir/usr/share/angrysearch/angrysearch.desktop"
- install -Dm644 angrysearch.svg "$pkgdir/usr/share/angrysearch/angrysearch.svg"
- install -Dm644 scandir.py "$pkgdir/usr/share/angrysearch/scandir.py"
- install -Dm644 resource_file.py "$pkgdir/usr/share/angrysearch/resource_file.py"
- install -Dm644 qdarkstylesheet.qss "$pkgdir/usr/share/angrysearch/qdarkstylesheet.qss"
+pkgver() {
+ cd "$srcdir/ANGRYsearch"
+ python setup.py --version
+}
- install -d "$pkgdir/usr/bin"
- install -d "$pkgdir/usr/share/pixmaps"
- install -d "$pkgdir/usr/share/applications"
+build() {
+ cd "$srcdir/ANGRYsearch"
+ python setup.py build
+}
- ln -s "/usr/share/angrysearch/angrysearch.py" "$pkgdir/usr/bin/angrysearch"
- ln -s "/usr/share/angrysearch/angrysearch.svg" "$pkgdir/usr/share/pixmaps"
- ln -s "/usr/share/angrysearch/angrysearch.desktop" "$pkgdir/usr/share/applications"
+package() {
+ cd "$srcdir/ANGRYsearch"
+ export PYTHONHASHSEED=0
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}