summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoTheEvolution2016-02-21 20:47:29 +0100
committerDoTheEvolution2016-02-21 20:47:29 +0100
commit82a59452f16e535fc9d7e67cd071ade67c38a721 (patch)
treea004c6bb308fa364af7f3882f85751d76991d251
parentd8895382ea64807d8703c45e5f80517d089519e1 (diff)
downloadaur-82a59452f16e535fc9d7e67cd071ade67c38a721.tar.gz
update to v0.9.5
-rw-r--r--PKGBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e2365d7ce1c2..f0867497e835 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,32 @@
# Maintainer: DoTheEvolution <DoTheEvo@gmail.com>
pkgname="angrysearch"
-pkgver=0.9.4
+pkgver=0.9.5
pkgrel=1
pkgdesc="Instant file search"
arch=("any")
url="https://github.com/dotheevo/angrysearch/"
license=("GPL")
depends=("python-pyqt5" "libxkbcommon-x11" "xdg-utils")
+optdepends=("python-gobject: desktop notifications support"
+ "xdotool: Thunar & PCmanFM to select file on path open")
source=("https://github.com/DoTheEvo/ANGRYsearch/archive/v$pkgver.tar.gz")
-sha256sums=("5336b4595ebbbab995fc3886c5fcd9c0c5a163f3215102e0a937f1480f0820b1")
+sha256sums=("763ccd218cf67359a768554bcbe78467b7da7552f3aa6bbbb65a728acce84969")
package() {
cd "ANGRYsearch-$pkgver"
- install -Dm755 angrysearch.py "$pkgdir/opt/angrysearch/angrysearch.py"
- install -Dm755 angrysearch_update_database.py "$pkgdir/opt/angrysearch/angrysearch_update_database.py"
- install -Dm644 angrysearch.desktop "$pkgdir/opt/angrysearch/angrysearch.desktop"
- install -Dm644 angrysearch.svg "$pkgdir/opt/angrysearch/angrysearch.svg"
- install -Dm644 scandir.py "$pkgdir/opt/angrysearch/scandir.py"
- install -Dm644 resource_file.py "$pkgdir/opt/angrysearch/resource_file.py"
- install -Dm644 qdarkstylesheet.qss "$pkgdir/opt/angrysearch/qdarkstylesheet.qss"
+ install -Dm755 angrysearch.py "$pkgdir/usr/share/angrysearch/angrysearch.py"
+ install -Dm755 angrysearch_update_database.py "$pkgdir/usr/share/angrysearch/angrysearch_update_database.py"
+ install -Dm644 angrysearch.desktop "$pkgdir/usr/share/angrysearch/angrysearch.desktop"
+ install -Dm644 angrysearch.svg "$pkgdir/usr/share/angrysearch/angrysearch.svg"
+ install -Dm644 scandir.py "$pkgdir/usr/share/angrysearch/scandir.py"
+ install -Dm644 resource_file.py "$pkgdir/usr/share/angrysearch/resource_file.py"
+ install -Dm644 qdarkstylesheet.qss "$pkgdir/usr/share/angrysearch/qdarkstylesheet.qss"
install -d "$pkgdir/usr/bin"
install -d "$pkgdir/usr/share/pixmaps"
install -d "$pkgdir/usr/share/applications"
- ln -s "/opt/angrysearch/angrysearch.py" "$pkgdir/usr/bin/angrysearch"
- ln -s "/opt/angrysearch/angrysearch.svg" "$pkgdir/usr/share/pixmaps"
- ln -s "/opt/angrysearch/angrysearch.desktop" "$pkgdir/usr/share/applications"
+ ln -s "/usr/share/angrysearch/angrysearch.py" "$pkgdir/usr/bin/angrysearch"
+ ln -s "/usr/share/angrysearch/angrysearch.svg" "$pkgdir/usr/share/pixmaps"
+ ln -s "/usr/share/angrysearch/angrysearch.desktop" "$pkgdir/usr/share/applications"
}