summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark2022-01-28 11:04:17 +0100
committerMark2022-01-28 11:04:17 +0100
commit4ff45ddb36dcc52468b1ddd2187eb55315d023dc (patch)
tree9922090b25a95367c135e4d3b6530ddf28a7af15
downloadaur-4ff45ddb36dcc52468b1ddd2187eb55315d023dc.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD18
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b6bfe20e07c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ani-cli
+ pkgdesc = A cli to browse and watch anime.
+ pkgver = 1.5
+ pkgrel = 1
+ url = https://github.com/pystardust/ani-cli
+ arch = any
+ license = GPL3
+ depends = grep
+ depends = sed
+ depends = curl
+ depends = openssl
+ depends = jq
+ depends = mpv
+ optdepends = vlc: An alternative video player
+ optdepends = aria2: For downloading episodes
+ conflicts = ani-cli-git
+ source = https://github.com/pystardust/ani-cli/releases/download/v1.5/ani-cli
+ sha256sums = 05e099aaab64b2343fc79c3f10acfb5c831679c4ed2956cf803e71f26dcd4f6c
+
+pkgname = ani-cli
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27fed7bcc53f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Mark Kostovetskyy <mark at sgtxd dot de >
+pkgname='ani-cli'
+pkgver=1.5
+pkgrel=1
+pkgdesc="A cli to browse and watch anime."
+arch=('any')
+url="https://github.com/pystardust/ani-cli"
+license=('GPL3')
+depends=('grep' 'sed' 'curl' 'openssl' 'jq' 'mpv')
+optdepends=('vlc: An alternative video player'
+'aria2: For downloading episodes')
+conflicts=('ani-cli-git')
+source=("https://github.com/pystardust/ani-cli/releases/download/v${pkgver}/ani-cli")
+sha256sums=('05e099aaab64b2343fc79c3f10acfb5c831679c4ed2956cf803e71f26dcd4f6c')
+
+package() {
+ install -Dm755 ./ani-cli "$pkgdir/usr/bin/ani-cli"
+}